DCS Updating Problem with MiG-21 Avionics.dll

I just spend 3 hours trying to make the latest DCS update. It would always fail when trying to delete the old MiG-21 Avionics.dll. Also trying to delete the file by hand would fail, stating I do not have the permission to do so even as an Administrator.

I eventually deleted the complete bin folder where the Avionics.dll rests, which worked.

When trying to repair DCS, it will download the missing files but again fail when attempting to copy the new Avionics.dll into the bin folder. Moving or creating any other files in the folder works, but trying to rename any file into Avionics.dll within the folder fails due to not having the necessary permission.

My suspicion is that the path/filename is blacklisted somewhere.

I have no files in quarantine as far as I am aware. Also disabling Avira has no effect.

Interestingly, since the previous DCS update Avira gets a hit on the MiG-21 FlightModel.dll, which rests right next to Avionics.dll. I have ignored this because DCS files frequently seem to generate false positives. Also I can move/rename/delete this file without issues.

Anyone has any ideas?

I don’t have the MiG 21 but if you want I can see if I can copy the file for you?
I can share it via Google Drive?

Avionics.zip (3.8 MB)

Here’s mine.

Thanks guys, but the problem was that the updater/repair was stuck because it could not delete the file I already had or put the new one (which it downloaded and put into the _downloads folder) in place in the “DCS World\Mods\aircraft\MIG-21bis\bin” folder. It seems that any operations involving any file with exactly this name in exactly this folder is prohibited.

I went ahead and successfully removed the MiG-21 module, which allowed the updater to run through completely so I am at least able to play DCS again. Reinstalling the MiG-21 doesn’t work though (fails again when trying to put the Avionics.dll folder into the \bin folder).

Interestingly, there is a FlighModel.dll in the “_downloads\Mods\aircraft\MIG-21bis\bin” folder now (which was downloaded today when trying to repair) which I am now also unable to delete.

So no more MiG-21 for me?

Not until @Wes reads this and helps you figure out how to unfchk your file system. Which he will. Because he’s a wizard.

Do not give up on your -21. It’s too glorious a monster!


1 Like

Taking a look at the details here it sounds like it’s something in how Avira works. A filesystem issue would go away when you re-make the directory, as it would:

A) get fresh permissions
B) due to the update of other files, end up in different disk sectors, avoiding a bad disk issue for that specific bit of data again.

Here is an example of Avira still blocking a file when disabled, that is quite recent:

What I would recommend for now is to make the directory is an added exception, disable Avira for the update and ensure the DCS Updater is being run as administrator.

If you run the updater via a Shortcut, edit the shortcut and check the “Run as Administrator” box. You can also see that option if you are getting to the updater via the Start menu or right clicking on the updater EXE file itself. Being an admin user account isn’t the same level of permission as run as administrator. If that does work, I would modify DCS to run as administrator as well otherwise I would suspect it would block DCS from using that file too.

I haven’t found any info on how Avira does these blocks but it’s disable mode seems to put it into a sort of “low power” state rather than “off”.

If that doesn’t work, we’ll hit up the drawing board again.


Thanks a lot for your help. I tried all this, unfortunately without success.

Perhaps I should try by uninstalling Avira altogether?


Built in windows defender is sufficient for most of us.

1 Like

Avira is having a field day. Now it also thinks the Viggen avionics dll has a virus. I say ignore and just for the hell of it try if I can still rename the file. No longer possible.

Dealing with and managing modern Anti-Virus/Malware/Ransomware software is a pain, and in some cases a good chunk of IT time. If you are comfortable enough as a “power user” to not fall for basic phishing scams and the like - @schurem is right, the modern Windows Defender is good enough. You can even pay MS for an advanced version as I recall.

Anyway, so long as your critical data is safely backed up - if Avira is taking away time to functionally use the computer than just toss it.

I haven’t used paid AV with Windows 10 at all because I got sick of playing manager.


Break, break. New tasking. Avira, redundant and obnoxious. Fire for effect, cleared hot.


Be sure to reboot the machine after installation and purge of the anti-malware malware.

1 Like