HDD cloning blues

So, long story short, because SSDs are getting cheaper and more accessible, I’ve been moving some of my HDDs over to SSDs. I transitioned from a RAID setup on my OS drive to 1 TB SSD and just today cloned my old 640GB HDD to a WD 1TB SSD. I was using a free tool, EaseUS, to do it.

Anyways, per my SOP, backed up my data on a 4TB USB drive before making the clone, did it and all that jazz, then went to backup my OS disk via Windows Backup… Only to run into a VSS error! Went around in circles trying to figure it out til I finally got smart and actually read the event viewer for the codes. Turns out EaseUS will give cloned partitions funky names, which results in VSS going bonkers because sometimes the names are unreadable characters. The rather obscure solution is to run a utility that can rename the GPT partition names, either setting them to blank or to a proper, readable name; once that is done, Windows Backup functions as desired and VSS doesn’t go haywire.

I used a utility called GPT fdisk to rename the partitions on the cloned drives, but there’s a couple others out there. I thought I’d bring this up because I went around in circles trying to figure out this problem and the obscure fix for it.

1 Like

I’ve never had a problem with Arconis True Image (free with Western Digital drives). I’ve done two OS drive replacements no problemo …

https://www.wdc.com/products/features/acronis.html

I think if you have a Seagate drive you get DiscWizard for free …

I’ve not tried that one though.

1 Like

My OS disk was a Samsung SSD and I’d read about problems with their software not recognizing newer disks, so I just cut out the middleman. EaseUS isn’t terrible but the strange error it induces in partition naming is just weird – even more so how Windows didn’t care about it until I tried to make a backup.

The Samsung Magician thing works, but yes it gets complicated on some drives, but I think it’s going backwards, not forward.

I had to use some command prompt and BIOS stuff or something to get it to work.

Had real trouble getting the OEM variant of Arconis True Image that is provided with Crucial to work. That pushed me towards Macrium Reflect Free; the interface is pretty simple and the feature set is light, but if you just want to image a disk and sort out a partition it’s straight forward. Link below.

https://www.macrium.com/reflectfree

Failing that, there is always a linux boot disk and dd if=/dev/sdX of=/dev/sdY bs=64K conv=noerror,sync status=progress

The thing with the Western Digital edition of Arconis is that you only need a WD drive on your system to use it. The source and destination drives don’t even have to be WD. For example, I replaced an aging Intel SSD (OS) with a brand new ADATA SSD with it. Easy peasy. If I didn’t currently have a WD drive connected to my system I’ll probably keep one around just to plug it in so I can use Arconis.

1 Like

My issue was that it wouldn’t spot any of the Crucial drives currently installed. Maybe the WD version is better implemented? As with most things YMMV.