iPhone broke my PC?!

This is a weird one and I can’t work it out and wondered if anyone else has come across anything similar.

I plugged in my iPhone to charge with usb cable whilst playing a game, first time I’ve ever plugged into pc so I get a coupe of pop ups saying it’s installing drivers etc, fine. After though the screen has frozen and whole PC as ctrl alt del won’t work or alt tabbing so I press the reset button on front of pc.

PC starts up normally but when I come to type in password to get into windows 10 the keyboard isn’t working and I notice the lights aren’t on it either (backlit keys)… So I hold down power button and do a hard reset and start up again - same thing… change USB ports - same thing… plug into powered usb hub and same thing! Tried a different keyboard and no go.

So I’m thinking it’s a driver issue, the iPhone drivers have caused some conflict in my pc so I go through the bios (the keyboard works) and do a roll back, restart, same thing!

Now I’m stumped and my next course of action is a complete windows reinstallation :weary: unless anyone has any advice? Never had anything like this before.

WOwza, tough one.
But let’s go in order.

Can you get to the BIOS screen?
Do the LEDs on the keyboard light up?

EDIT: just read actually all. So keyboard works in BIOS… odd one, this.
I’d be cool if you could try a PS2 keyboard…

I don’t actually have Win10, but could you try to boot in Safe mode and check some Crash logs?
It’d be cool if you could check with BlueScreenViewer…

1 Like

When I switch pc on the keyboard has power, backlights come on and if I let it continue to windows login the lights will go off, come back on then go off. Like it’s trying to load in?

Yeah it works normally in bios but not backlit so I’m guessing it’s just being a generic keyboard at that point as no drivers are loaded at that point.

It must be drivers as the USB ports work but when I started in safe mode the keyboard still wouldn’t work…

I could have messed up the USB drivers.
That’s why I was hoping you had a spare keyboard with PS2 plug to check…
Obivously the problem isn’t at BIOS level but further down. Or up- depends which way you look at it.

EDIT: Does your mouse still work?

1 Like

Was just about to ask about the mouse aswell … could it have been a power spike and messed with the usb controller?

1 Like

I’ve actually found a report on that problem.
The solution is a big sequence of stuff to type… Which Mace can’t do as his keyboard doesn’t work…


  1. Type troubleshooting in the search bar.

  2. Select Troubleshooting.

  3. Select View all on the top left corner.

  4. Click on Hardware and Devices.

  5. Follow the on-screen instructions to run the troubleshooter.

  6. Check if issue persists.

If the issue persists, I suggest you to uninstall and reinstall the USB drivers and check if the issue persists.

  1. Press Windows Key + R Key.

  2. Then type “devmgmt.msc” without the quotes and hit onEnter Key.

  3. Expand Universal Serial Bus Controllers.

  4. In the uninstall dialog, make sure you select the option to delete the driver package from the system. This causes the driver package installed earlier to be deleted.

  5. In the Action menu of Device manager, select “Scan for Hardware changes” option. This will cause the device driver to be reinstalled. Once the driver is installed, close all windows and restart the computer.

1 Like

The mouse did work when I had to navigate through the Recovery sections in the BIOS (I think it was some Gigabyte sub windows programme but Windows definitely wasn’t running) but it wasn’t when I get to the Windows login screen as usually a left click brings up the password box.

I have a Belkin power surge protector 4-way socket so shouldn;t have happened lol. I did wonder about static somehow causing this and blowing something on the MB (as I’ve had happen before).

So that means most/all of the USB ports are useless.

My take is that if you don’t want to reinstall everything you better find a PS2 keyboard IF you have a PS2 port on your motherboard anyway…

It’s definitely a frakk up between phone drivers and USB ones.

Good find! But as you say I have to actually type stuff in Windows lol :thinking:

It’s looking like a total HD wipe and reinstall is on the books…

I don’t think there is a PS2 port on the MB… even if I could find a PS2 keyboard these days lol

Never had a problem with my Android phone lol

1 Like

Sadly the proprietary nature of Apples products does that stuff. Well, I think, at least.

Sorry for that…

1 Like

WAIT! Try one more thing!

Power off the PC and UNPLUG the power cord.

Leave it untouched for a good 10 minutes then try again.


Did you just tell me to ‘turn it off and on again’? :laughing:


I’ll try that tonight :smile:

What’s your thoughts on that?


I know it sounds odd BUT removing power (included pulling the cord from the machine) completely removes power and sometimes it does some magic.

I swear it worked for me. Sometimes.

I was about to tell you to also remove the battery from the motherboard but… I leave that to you.
If you’re really into re-formatting the beast then, it’s worth a try.

I love the IT Crowd- much more realistic than non IT folks think it is.

1 Like

:smile: Magic you say?..

The IT Crowd is great, still watch it occasionally now on Netflix :grin:

1 Like

IT technicians survive on black magic and black coffee.

1 Like

Do you have a laptop to plug the keyboard in to check … Just to make sure it’s not any weirdness going on with just the keyboard …

1 Like

It’s just that it works in the BIOS screen…

1 Like