OpenXR Dev Tools for WMR v106.2104

A bit of a nice surprise, as a new OpenXR version arrived in preview. The big change in this one, and why it’s worth looking at, is that they have some new reprojection modes for sims struggling to maintain headset framerates (stares for an uncomfortably long time at MSFS VR until it can’t stand it anymore and has to look away in shame).

Just go to the Microsoft Store app in Win10, click the … next to your Avatar on the top right and use ‘Downloads and update’. That’ll grab latest. If you don’t have it, you can get it here:

The new Motion Reprojection now works at 1/4 framerate, so (fairly incredibly) you can get a headset working at 90Hz, but the sim only needs to pump out a framerate of 22.5 FPS. (Now switches stare to DCS and its lack of OpenXR, but it just ignores me and smiles happily back obliviously).

You need to opt-in to the 1.6.2104 version using the ‘Use latest preview OpenXR runtime’ and turn on Motion Reprojection (you can try Automatic as well, that works but can be a bit juddery when changing mode), like here:

I’m finding that this new update is great. You obviously have to put up with reprojection artifacts sometimes, but for a civil sim or just tourism flying, it works nicely.

5 Likes

Oh My God Reaction GIF

Gotta try this!

2 Likes

If the headset is set to 60Hz mode, then theoretically the sim only needs to run at 15 frames a second. It’ll look bad, but it’ll be a high refresh type of bad. :slight_smile:

4 Likes

I am getting a bit lost…

Does the reprojection adapt to the fps reached by the sim?

I mean can it switch between reprojecting from 22.5 fps, 30 fps or 45 fps or with the “reprojection always on” it just sticks to 22.5 fps irrespective of what the sim delivers in a given moment?

HEEELP! :slightly_smiling_face:

1 Like

Think it will work with X-Plane? (I’m away from my PC right now…but will try it tonight…)

The mode ‘Automatic’ will switch to the highest fps the sim is giving it, so in steps of 90 (off), 45, 30 and now 22.5. For ‘Always On’ it’ll see what the frame rate is when started and stick to that (usually either 22.5 or 30 for MSFS).

In the OpenXR Dev tool try ‘Automatic’ first. I found it better for ‘Always On’ but mainly because it caused more artifacts ‘changing speed’ (I think) because of such variable FPS from MSFS where I was flying.

1 Like

Does XP11 support OpenXR? I haven’t looked for a while, but if it doesn’t then this won’t help. I think XP11 is like DCS and still on SteamVR direct (and then the WMR for SteamVR bridge if needed for WMR). Those two things haven’t been updated for this. Both Valve and Microsoft and just going to update the OpenXR path now, or rather spend more effort in that than the older stuff.

Quick search says no…XP does not support OpenXR but it has been requested…

1 Like

I’d bet it would be likely for XP12 then. They support Vulkan already, and OpenXR basically comes out of the same standards group

3 Likes

So when DCS gets the Vulkan update…?
One can hope, right?

2 Likes

Well, that works really nicely with MSFS! It gives a very fluid VR experience on my system. :sunglasses: :+1:

2 Likes

Sorry for the kitten video. I allow myself one per year

6 Likes

That’s how it starts…

1 Like

OMG, that kitten is soooo cute! What were we talking about again?

2 Likes

The Kardashians.

2 Likes

4 Likes

I must say that you put it to good use!

Testing 22.5 reprojection in MSFS.

Funny I have just spent a couple of hours tweaking the settings. I found turning ASW off in Open XR and setting the slider to 70% gave me quite good results. Shame I cant use FPSVR to monitor stuff

In case some of you haven’t heard, OpenXR v107 was released a few days ago that fixed the issues with MSFS. In my case even after the update, the Systems Status page showed an older version. But clicking on the About button in the upper right hand corner displayed the correct version, 107.2106.1002, and updated the Systems Status page. I’m trying it with Motion Reprojection Always on and CRS at 75%. Working well so far. I tried turning up both custom render scale to 100, setting MR to off and Auto, but nothing seemed to work as well as Always on/75.

Edit: I should have said that this is with the VR preset in MSFS on default settings. System specs: Zen 5 5600X / RTX3080 / 32 GB 3200

2 Likes
© 2021 Mudspike.com | Articles Website | Forums Rules & FAQ