Please help with virpil war brd base


so this is what it is showing for my x and y axis on the base everything else works but theres nothing i can do to fix the link error has anyone came across this?

1 Like

I can literally understand nothing of that sccreenshot.

Could you try and take a higher resolution one, and maybe explain with a few lines of text what’s going on?

1 Like

Ok I’m sorry I’ve never posted anything like this. Please excuse my ignorance. So I have everything working in the config tool. The only thing that I have issue with is the warbrd base x and y axis. In the config tool it has link error 254 on both x, and y axis. Just the axis in the base, so I’m assuming it’s something going on in there. But I don’t know how to troubleshoot cams and sensors and was wondering if anyone came across this.

1 Like

all the screenshot shows is my x and y axis having the link error 254 and everything else is normal

1 Like

No worries, you don’t have to apologize. ^-^
Nobody knows everything.

Let’s see…
I’m going to ask a couple of questions that may look odd but trust me they’ll help. I’ve been an IT my whole life and I like this sorta stuff.

1 Like

First: Did you just get it? it’s the first time you connect it to your PC

or

It suddenly stopped working even though you had it for some time and never gave you problems?

Is it connected directly to the PC USB ports or to a USB hub?

(just for clarity, a USB hub looks something like this )
image

ok so this is the initial setup, just unboxed it today.
and it connected straight to mobo usb

1 Like

thanks for coming through by the way im stumped man anything new i can try will be great lol

2 Likes

Heheh no worries, we’re a friendly bunch here.

Got to go to bed now- living in central Europe and all that.

But if doesn’t work straight out of the box it could be a defective unit.
One thing is I’d try is , unplug the base, turn off the PC, on again and plug it back in a different USB port.

I don’t expect it to work but let’s change something at least. :wink:

Also maybe if you have any other PC you could plug it in… if it still shows the same problem it could really be a defective base.

Hey @jimmy, welcome to MUDSPIKE. Lots of Virpil love here. Did you calibrate your axis? If not, you will get inaccurate output. This guy makes the best Virpil software videos. He goes over calibrating axis @ around 7:33.

1 Like

its not recognizing the axis in order to calibrate it. i understand the software and how to use it its just shooting the error code 254 on those two axis

2 Likes

heres a much better screeny

1 Like

I take that you tried the official VirPil forums?

And just to make clear, you are calibrating it in the VPC software, right? Not in windows game controllers?

On second thought… Try taking the bottom plate off and check that the axis sensor connectors are in fact connected.

2 Likes

According to the screens- I’d say so.
It’s interesting that the software itself is giving him a direct error reading. Like it’s telling
him something is in fact wrong.

EDIT: I finally managed to check the VirPil website* and it reports this:

  • Sensor Link Errors - Allows diagnosing axis input errors caused by physical hardware problems or incorrect profile settings that prevent the sensor from communicating expected values. Should always report as “0”.

I’d say @jimmy you really have to contact VirPil to tell them this. I honestly think the thing is non functional.

That said, do what @Troll said first as long as you don’t void any warranty (I’m not familiar with VirPil hardware- I have no idea if you can do it without removing any soft seal)

1 Like

And according to the same screen I’d say those are generic calibration values. I.e. it looks like it’s not calibrated. But the link 254 indicates there’s no signal.
There is a signal on rY and rX. I’d have to know more about how @jimmy set the hole thing up.

The WarBRD I got for review can with the whole bottom plate off for the user to attach.
So I doubt taking it off will void any warranty.

So, @jimmy, show me the profile page. What grip did you select?

Ah! Ok, I got you know.

Brilliant! Good to know! :slight_smile: :+1:

The more I think about this, the more this is it …
The software shows the axis as present but the sensors aren’t. It’s very much likely that either in the assembly phase or during transport the sensors got detached/never fully connected well.

1 Like

Or, that the software somehow designated the X and Y sensors rX and rY? Or, if he’s using the Alpha grip, there simply are no sensors selected for X and Y.

You can click each axis line in the software and select which sensor does what.

OK everything is connected i tried that before posting and i noticed the errors during initial setup further driving me towards pre existing hardware or some deeper level of the software i dont currently have access too without a dev

1 Like
© 2021 Mudspike.com | Articles Website | Forums Rules & FAQ