Stellarium and X plane connection

Really eager to get learning/practicing the Celestial Navigation that was covered in the reference section.

I seem to be having issues getting X plane and Stellarium to talk to each other.

For the connection side with X plane should I be trying to use the UDP ports or via the “Other mapping apps”? ( I’ve got both turned on)

In Stellarium, I’ve go the remote control setting to the output port number shown on the UDP “we send from”

I’ve installed python 3.8 64bit and run the Run batch file after I have the two programs running. When I run that there is a momentary flash of the CMD run screen and that’s it, no confirmation or errors, etc shown.

Silly question but is it necessary to have Caspers Python file placed in a particular folder on the system or X plane?

Is it necessary to use the python interface plugin with x plane? From what I can see that only runs with python2.7 but of course I could have this wrong!

Any help or advice would be greatly appreciated.

Welcome to Mudspike @Captrawdata !

It is great to hear that you would like to give this a try!

I’m away from my PC right now but I’ll get back with you as soon as I can. The person you really should talk with is Casper. Calling @TheAlmightySnark :grinning:.

Hello @Captrawdata and Welcome to Mudspike!

My application can be run from any place on the computer. It is not directly talking to either X-plane or Stellarium but is using standard methods to talk to X-plane over the UDP protocol. The app sends a code to X-plane, that then responds by sending a stream of UDP packets with it’s position. This gets wrapped up into a TCP/IP package then is then parsed on to Stellarium(the Remote Control Plugin) who then updates the position in Stellarium.

The application should als you for an IP/PORT combo(you can usually leave it on default). So I am not quite sure why it’s instantly flashing away. You can also directly run the application by opening a command window, navigating to the installed files and typing in ‘python main.py’

Let’s say you’ve put it on your desktop and you open a command window, you then navigate to c:/Users/You/Desktop and pres enter. Then you type in ‘python main.py’

If something goes wrong then it should also pause the window and not instantly close it.

Another option is adding another line to the .bat file that just says ‘pause’.

Could you tell me a little bit more about your software setup?

Hi PaulRix, many thanks, looking forward to trying to get my head around learning it.

TheAlmightySnark

Thanks a million for the info. I have to admit I have no experience of using Python previously which is probably obvious of course.

I did go down the route of installing python 2.7 and the python interface into x plane earlier on, could this be causing the issue at all due to a conflict with Python 3.8?

Set up is xplane 11 on Windows 10

thanks again for coming back to me on this

@Captrawdata, I’m sure Casper will get back with you, but in the meantime, here are the settings I am using…

With X-Plane and Stellarium running, I start Casper’s app and get the following:

All being well you should see something like:


You should see it refreshing with the lat/long being pulled from X-Plane, and the response message from Stellarium.

This should mean that Stellarium’s position is being updated with the position of your aircraft.

I hope that helps…

You X-Plane people get all the good addons and aircraft variety.

@Bloodreina, To be honest asking X-plane to send you data and to send something to X-plane is relatively trivial. DCS is a bit trickier since you need DCS-BIOS, and FSX requires FSUIPC to communicate with it. Though it’s been ages since I’ve tried the last one.

This means that for X-plane I can happily write standalone application and talk to any single bit of information inside. Well it’s UDP so it’s more of a two way screaming match…

@Captrawdata it looks like X-plane is sending UDP data to 192.168.0.1

What did you tell the python application on where to send the data?

Yeah I’m figuring out what I’m doing wrong that Python is opening.

Is there a way to check that my python is installed/ working correctly but maybe doing a test or running a different programme perhaps?

Many thanks

I think it’s due to lack of module of your python environment. :grinning:
All you need to do is to check whether you have “pip request” installed. And if not, you should install it.
Here is the way:
Open CMD windows, and type “pip install requests”. That’s all.
I hope it can help.

1 Like
© 2021 Mudspike.com | Articles Website | Forums Rules & FAQ