USB trouble (solved)

Hey guys, lately my TM gear has been resetting randomly. In other words, all of the LEDs go dark for about 2 seconds, then light again which is accompanied by the Windows new device detected loading chime. I haven’t determined if this is only when running a TARGET GUI script, or happens at other times. Still mentally logging the behavior. It’s very annoying in DCS, because most aircraft are programmed with TARGET scriptt. Once the hardware recycles, the script unloads and whatever aircraft you are flying becomes uncontrollable.

Most of my peripherals are on powered USB 3 hubs, and I have disabled power management of all USB hubs in Device Manager. Not sure what to try next. Windows 10 with latest patches.

I had similar issues starting back a few years ago. I don’t think it is a Windows 10 thing but I have all of the patches installed there too.

Sounds like you did some of the same things as me:

  1. Find and turn off USB power saving options in the Control Panel;
  2. Buy a (quality) powered hub;
  3. Witchcraft and magery;

It wasn’t target for me as I have never delved into that.

I have no idea what managed to make it go away, but from time to time I still encounter it (months apart and hopefully it stays that way). Its frustrating, for sure, but I wish you luck.

Thanks Fridge. I found it {slaps forehead}. I disconnected every USB device on my system, and then plugged in each one systematically one at a time while I observed device manager. I found that two of the ports, which are somewhat hard to get to, but adjacent to USB3 ports, are actually USB2 ports. I had had a USB3 powered hub plugged into one. All is good now. Back to DCS 2.5!

3 Likes

OK, not so fast Kemosahbee. USB resets are happening again, causing the scripts to unload while flying. Pretty much ruins your day…

Capture

Event System and App logs look clean, Device Manager looks fine. T.A.R.G.E.T is latest version.

So, the investigation continues.

1 Like

I seemed to have unwittingly solved this problem. It was getting really bad, as in USB devices were power-cycling about every few minutes. I tried a whole bunch of things to troubleshoot, and finally decided that it was either the motherboard or the power supply.

Looking at the mobo, I went into the BIOS configuration and not seeing anything that jumped out at me, began tinkering with the Asus presets. I tried the Performance one first, and that rendered Win 10 unbootable with a generic error message. Next tried the Normal setting, and seeing that it did not remove the CPU overclocking, decided to run with this for a few days. Happily, I haven’t had a single issue with USB devices since that, my system has been very stable, and I don’t detect any loss of performance. It’s faster if anything, posting higher frame rates in DCS 2d and VR.

I suppose that my BIOS configuration became corrupt somehow, and resetting it to the Normal Asus preset solved the issue.

2 Likes