VR News - WMR News


I use Rift S, and the standalone DCS client, so I can’t speak to Steam VR/WMR. I do know that for IL2, which does not support Oculus natively, it uses Steam VR and I found a way to bypass Steam VR and it greatly improved performance. Confused yet?

Using Open Composite may or may not work with a WMR headset, but it might be worth trying. Basically its lighter version of Steam VR api as far as I understand it.
OpenComposite (AKA OpenOVR) - bypass SteamVR for Oculus Rift - Virtual Reality and VR Controllers - IL-2 Sturmovik Forum

If you have poor performance with a 2080ti I can almost guarantee you have some settings issues. Sounds like you may have a reprojection issue or some of the steamVR settings are fighting or multiplying WMR settings. Hopefully the Reverb/Odyssey guys can chime in with their settings.

1 Like

At this point in the VR game one thing is certain and that is the software is a finicky beast. Seems like I spend almost as much time tweaking settings as I do playing. But once you dial it in the experience is so worth it. Really looking forward to the next generations of headsets.

1 Like

I agree. That whole Steam supersampling multiplier thing really screwed me up for awhile (then they got rid of it I think…). Editing INI files and stuff should not have to happen if they want people to really embrace the technology.

But like you said…once you get it dialed in…it is so awesome. Over the past couple of days I’ve spent hours in VR in X-Plane in that Dornier just loving every second of it. Looking down at the Orbx ortho going by and seeing so many unique patterns and structures.

Same with DCS World. Been getting back familiar (well…I actually never really was familiar) with the Hornet and taxiing around the Supercarrier in VR and doing launches and recoveries…I feel like a kid in a candy shop.

Now getting ready to don the headset and check out the RW Twin Otter in VR and see what I do and don’t like about it.

I too have an Odyssey + and yes I have to run WMR then SteamVr (which loads Steam). I’ve not tried the alternative that @Gunnyhighway suggests. [1]

I only have a 1080 (NON Ti) card with 8gb VRAM.

I’m using tweaks from a video (around here recently I think) and getting 55-89. I almost hit 90 once or twice and it stays around 70 FPS in NTTR, though with simple missions. Without the tweaks it was about 45-55.

And yes there is a slight loss in graphical fidelity but, A) in the O+ I really don’t notice it; after almost 2 years now I’m ‘used to it’, and, B) the smoothness is like butta, baby.

Just simply flying around (NTTR and PG + Supercarrier) is a joy. Wish I could capture, for others on the fence concerning VR and Seat Shakers, the sense of immersion (there’s that word again) as I…cruise into the break, feeling the engines pitter-patter, roll hard (left of course) transmitting a slight shudder, then smoothly add on the G, feeling the rumble scale to my right hand, literally. I can tell my G-state to within +/- 1 G anymore.

Got it tweaked, finally, such that when you pull hard enough so that the AOA hits a certain point ('Vape’s coming of the wings for instance) it really starts to rattle. Think of those “WAKE UP” rumble strips alongside the roads for when you ‘wander’ out of your lane…whew, sorry, where was I :)…

Here’s the YT concerning the tweaks:
DCS VR Optimization (

[1] In fact I have seven apps running each time in DCS. It’s a process:
Those are in addition to WMR (again, SteamVR automagically runs Steam).

…turn on my seat shaker, position the HOTAS, pull all “remove before flight” pins…

I have 32Gb RAM. The Razer Cortex claims to give me back .5 to .9 GB prior to running, depending on what I’ve done before. Jury still out on this but it’s caused no issues so far.

It’s still there, at least on SteamVR Beta; they just moved it around in the UI. I have mine, with the above gear, set on 1.5 (1.0 in DCS). Nothing else on.

Where is That!?!. There is the setting I cant find! “the one above on 1.5 and DCS set to 1.0” Where is this?
I set the video at 100 for home and I tried 150 for DCS. I tried 100 in DCS. No difference. I did this in SteamVR. Ahhh I need to turn down WMR.

I don’t touch anything in WMR. It’s set to 90hz; the way it’s always been and what the O+ runs at. In SteamVR:

In DCS | Options | VR | Pixel Density (PD) = 1.0.

1 Like

Its late. But I cant go to bed without saying THANK YOU guys. I got my 90 FPS. I then turned up some eye candy and now I am hitting 40 to 60 but its sooooo smoooth. I am really greatful for your advice. I put everything at 100%. Then I made sure the Reprojection was off on the text file with the // in front of reprojection. I still got 45 untill I disabled smoothing in Steam VR settings.
I just saw the 1.0 thing. Really, PD is set to 1… Ok… I ll go for it.


Awesome man enjoy!!


Turned off V Sync in Nvidia ctrl panel and in game. DCS now regularly plays at 60 to 90 fps. Looks good too. The biggest winner was Great Battles. It hardly moves from 90 FPS. I played my butt off this weekend.

Yeah, IL-2 GB has great VR performance now. They even increased the graphics by going to deferred lighting and increased performance as well.

1 Like

Do you happen to have your NVidia settings for that sim? What card are u using?
It’s so darn pretty now

I haven’t touched the nVidia settings…I think? I can check.
Using a 1080TI.


Hey Maico, do you mean G-SYNC in the nvidia control panel? Lately I’ve noticed DCS not looking so well In VR, and I didn’t think about G-SYNC, which I definitely use in 2D. I pretty much leave it on 100 for everything. Will try disabling.

Sorry @chipwich, my monitor is not Gsync and I don’t have that in my Nvidia Ctrl Panel. I did everything described above. It made DCS and IL2 look good. Then I disabled V sync in game options and in Nvidia Ctrl panel. BAM!!! Big increase in Fps. Try it.

1 Like

Im using 2080ti and i was a mess. Thanks Norway! Your suggestions got me there.

Im using 2080ti and i was a mess. Thanks Norway! Your suggestions got me there. Biggest pain was disabling reprojection. Once that was done I put VR ingame setting Pixel density to 1.0 in VR Tab. Turned off VSync and now I’m at 90fps.


Vsync was messing with me as well after a recent patch, could be driver related, not sure. Disabling it made VR silky again.

1 Like

This looks like an interesting update:

This bit might help DCS a fair bit on VRAM usage, will try it to find out:

  • Reworks how graphics buffers are shared with SteamVR, reducing overall GPU memory utilization in most cases.

Unfortunately, a stutter-fest for me. DCS VR preset. Similar dissatisfaction in the first 6 comments in Steam. Wondering if it’s Win10 related.