X-55 and ts3

So I figured out why my x-55 was causing my computer to be all stupid when I unplug it. I had this problem before but had solves it so I was confused why it was misbehaving now. Some interwebz research jogged my memory

In order to use the hotas for push to talk, the keybind capture method needs to be on default. Unfortunately this is the exact thing that causes the x-55 and ts3 to not play nice, and forces people to hard reboot after unplugging the x-55 because their mouse because useless and the computer basically unresponsive.

So I’ve fixed my crashing but am back to not being able to fly and voice chat at the same time.

You know…my Warthog won’t work in TS as a push to talk switch unless I run TeamSpeak in Admin mode…

I run almost everything in admin mode since as soon as one thing needs it they all need it.

I think it started with TS tbh. PTT wouldn’t work at all if I was playing a game unless I had TS in admin mode. But that started making the game not work until I put the game in admin mode as well. Basically teamspeak is just a terrible application :sleeping:

The X-55 USB’s controller are really twitchy. I got around this but basically not unplugging them. If it kills your mouse pointer then you can press the ‘Windows Key + R’ and do a

shutdown -r

…to cleanly reboot. On Teamspeak I think I just mouthbreath a lot and do the voice activation thing until told not to. :slight_smile:

2 Likes

I found that I had to bind my TS PTT to some outlandish key combo then bind that to a button using the X-55’s software in order to get it to behave itself.

I also had the “number station experience” when I unplugged the controller and had the impertinent to want to use my mouse.

Thought I had fixed it but apparently not. Or maybe it just hadn’t taken effect yet. We’ll see next time.

Might be that using it for PTT with anything (discord included) causes this behaviour. It had definitely stopped when I wasn’t using it for PTT.

I mean I guess I could never unplug it but really that’s not a proper solution in my opinion. Hoping to find the solution I had before. Maybe the key combo then x-55 trigger will work.

I had the same issue with my X52pro until I just made a profile for it that directed the worthless mouse button into left alt and I just set left alt as my PTT.