A10-C startup EAC troubleshooting

I have been having some trouble getting the EAC to arm, the switch won’t stay in the arm position. I’m guessing I’m missing some critical step. My startup procedure is based on the built in tutorials (skipping tests):

Battery on
Inverter standby
Oxygen on
Radios on
Boost pumps on
APU on
APU Gen on
AC Gen on
Engines on, one at a time
APU Gen off
APU off
CDU on
EGI on
SAI uncage
MFCDs on
IFFCC BIT, then on
SAS on
TO trim
DTS upload
right MFCD to CDU page
CMS standby
wait for INS NAV RDY
press NAV on CDU page
set navigation mode to EGI
Radar altimeter on
EAC arm
Anti skid on
Nose stear on
Ejection seat arm

Any Ideas what I’m doing wrong?

Update! I just tried again, same procedure, and this time it worked. User error confirmed!

The cause was that maybe you hit NAV on the CDU to soon. Did you let it allign untill T = 4.0 0.8? you can hit NAV earlier as some sort of emergency quickstart. it will say NAV READY on top. Under ideal conditions you should let it completely allign until the beforementioned values. NAV READY should then flash.


That sounds very plausible, thanks!