Anyone having trouble launching MSFS this morning?

I’m guessing it is due to the update server being maxed out, but I am getting a CTD when trying to load the sim, just after the loading music kicks in. Anyone else?

I played it a couple hours ago. Then saw the link by @Poneybirds about the update this morning. Re-launched it, and it took me to the MS Store App to update, launched the sim, and now it is doing the 14.77GB download update.

hmm it just downloaded about 1 gb and thinks it’s patched…but the CTD is still happening just as the loading music starts (with the desert scene in the background). It worked just fine yesterday. I’m guessing I will have to reinstall the whole thing :neutral_face:.

Well, I tried. The VR update got me to dust it off again. Now it wants to update 42+ GIGIBYTES! Gonna have to wait. Pretty sure I already know how it’s going to run so, no hurry.

Paul, try to empty your community folder first, it‘s pretty much the only place where your installation could have become non-standard.

I just tried that, as well as removing the Carenado Mooney from the official folder (I purchased it last night as it is on sale). Still no luck with the CTD though.

Anything useful in the Windows Eventlogs?

There is a detailed FAQ of Asobo for when the game crashes. You might find something in there. It’s a lengthy and tedious process to follow all steps - so be prepared to spend some time and patience if you go that way.

Hope you’ll be able to sort it out soon!