DCS 2.9 Disables A-4 DO NOT UPDATE

DO NOT update to DCS 2.9 if you have any user MODs as 2.9 apparently specifically searches for, at the least the A4

This breaks the use of DCS I’ll go with xPlane on STEAM! Glad I haven’t bought any MODS from ED

1 Like

Good looking out!

Works just fine over here.

Does the STEAM version still work?

New versions of DCS can be hit or miss on mod compatibility. Most of the major mods can make whatever update/fix they need in a day or two and they’re back up and running. The actual paid modules usually run without a hicup, though occasionally a particular feature will require fixing after an engine update.

Just either delete or rename you mods folder and DCS should run without issue if it’s crashing with the A-4 installed.

Amazing… All I know is I got the update notice and updated and when I started the game it said it had found an unauthorized MOD.

I did a thorough HD and Registry cleaning using cCleaner, reinstalled OpenBeta, and copied the A-4 Mod.

The first time I did this with 2.8 there was no MODS folder, this time installing it had a MODs folder just like the non OpenBeta

It may be that the downloader is now pointing at the “straight” DCS 2.9 not the OpenBeta version.

I don’t know, I’m just an angry old man who was really looking forward to flying the A4 sim before I committed to other MODs

Yeah, with major updates sometimes some stuff gets a little worse before it gets better. Sometimes it’s just a matter of repairing the installation or restarting fresh again…

Hmm that sounds like the mod is not installed correctly. A mod that is not installed correctly just wont run, there’s no integrity check for mods. You’d normally only see that with a paid Module that has somehow gone out of license.

1 Like

The mod worked before upgrade.

Please Elaborate, so we can investigate.

Mods do not go into the \DCS World\ Folder, they go into \UserProfile\Saved Games\DCS\Mods\

If it’s saying un-authorized, then it’s installed wrong.


2.9 and no issues with the A-4.

Same. All OK on my end. (Not using Steam)

No issues with the Scooter and 2.9 here. Oh Snap! Someone pimped my ride.


It works fine for me, I was trying to help out the OP there.

1 Like

The A-4E was the second aircraft I tried after the update. No issues with it for me either. Not using Steam.

I had to check. No issues for me :salute:


The plane works for me too, but I’ve read there’s a problem with radio and maybe navigation:

1 Like

Retrying DCS OpenBeta. (Should I also install DCS)
Verified C:\Users\Mike_Sr\Saved Games\DCS.openbeta\Mods\aircraft\A-4E-C
Deleted \A-4E-c and recopied from extracted folder
Deleted all Identifiable TEMP files & Folders
Deleted Program Files DCS and DCS OpenBeta Folders
Ran cCleaner - Registry
Downloaded Fresh Copy of Installer from DCS World 2.8 Open Beta
Verified MD5 70ff052cde38e28b5335f649d0a31ad8
Ran Installer - Updated itself to Version
How can it be “Copying files from C:\program files” when I deleted the identifiable folders?
Installation completed Successfully
Started - How did it remember my Log-In infor after Registry Clean and Temp Folder Clean-Out
Worked This time and AFAIK I did everything the same???

May have a memory problem as it crashed when trying to run the Training Mission, but at least the module is no longer “Unauthorized” upgrading to 32GB from 16GB, hopefully tonight.


Hey there @spiritualmadman and a belated welcome to Mudspike! :mudspike:

Gotta love computers…

Smash Old School GIF by Mediatool

Yeah, DCS likes that!