DCS integrity check fail - help pawease

Just tried to join the same server @Maclean and I were playing on last night, and I am now getting a “NON pure client error”

My integrity check icon is green when I load the multiplayer lobby. But when I go to connect to a server with integrity check it goes red and stays red. Clicking on it gives the following info.

textures/farp_2048 @ mods/terrains/nevada/vfstextures/assets.zip
textures/grass_n_4 @ mods/terrains/nevada/vfstextures/assets.zip

Which I assume is files it doesn’t like. But I have no mods, and I can’t see what changed from last night to today??? Any help on what to do ?

{EDIT} I have just jumped on a different server with integrity check and I have no integrity problems joining that… I am confused.

Step 1 - verify game files.

Step 2 - people who actually know about DCS can help you.

In patch 1.5.7 ED decided they hadn’t own goaled in a while and changed the IC system from checking a few important files to checking the entire install. This means terrain mods, cockpit mods, paint schemes not installed a specific way, will all cause you to fail IC.

Delete all mods, repair. If that doesn’t work it means some mod files got left behind. In think there’s a clean install command in that case.

Enjoy the bland new existence and know you are now safe from the five cheaters on mp.


Thanks @near_blind and @Rhinosaurus

I guess I will use @SkateZilla tool to verify my install but I do not run any mods. So I am confused as to why I now have an integrity problem from 14 hours ago…

[As well as the dreaded memory leak problem.]

Run Clean First, then repair.

HI Skate. Thanks very much. This is what I did, Great tool by the way.

I ran clean nothing there. Ran repair, that came up good.

Tried to jump into “through the inferno” server and still had the following error’s[quote=“Bogusheadbox, post:1, topic:4564”]
textures/farp_2048 @ mods/terrains/nevada/vfstextures/assets.zip
textures/grass_n_4 @ mods/terrains/nevada/vfstextures/assets.zip

So I located the zip folder which I assumed held these files. @DCS/mods/terrains/Nevada/vfstextures/assets.zip.

I deleted then entire zip, then ran your utility for repair. It repaired. I then tried again to jump into “through the inferno” server and the same error.

But its only happening on the “inferno” servo, not on other servers that have an integrity check.

Hashtag-- still confused - with a huge memory leak.

there are bug reports involving some texture files when switching maps and stuff, will see if another person can verify, my GPU is InOp after a small Fire due to PCIe Short from fans rubbing.

Cheers mate. Sorry to hear about your comp…:confounded:

yeah, lil set back,

lower GPU Fans were rubbing the PCIe Flatt cable for the 2nd GPU, so when in XFire Mode it wore the insulation off and caused a 75w line to short/arc, which sparked and caught the cable on fire which melted some mainboard parts and blew out some of the GPUs VRM Array,

Lucky for me I have a huge box of unused mainboards and GPUs that I can strip components off of, I just ran out of solder and work all day the next few days, so this weekend I’ll likely finish replacing the VRM components on the GPU.


I’m strangely aroused right now.

the only dollar bills I’m throwing at these are the ones I give to the cashier at the electronics shoppe for the solder.

1 Like

Bugger, that’s a shame. To be honest I’ve never seen a cheater in my DCS life. Have many people been caught?

I’m admittedly pretty salty about this. I don’t know what the primary motivation for this change was, but combating notional cheating was given as a justification. I haven’t seen anything that was provably cheating since FC 1.12, and that was MiG-29s firing Phoenixes while traveling at Mach 3, so I’m not sure how effectively banning texture mods would fix that.


Same same, it made using mods and sim data a pain in the hiney since they decided that the datalink thing was disallowed.

Huh. Guess I won’t be using Ricardo’s A-10C cockpit anymore. That’s a shame.

it’s not PBR Ready anyway…

I’ve never seen cheating as such. Only in the sense of gameplay.

Do we know what happens on the Russian servers, though?

OK, so for more strangenessessessessess.

After giving up on the integrity check fail on one server only last night. I decided, what the hell, lets try that server again today.

All good, nothing wrong…

I don’t understand it.

Next time we’re on TS, I’d like to hear how that’s pronounced :stuck_out_tongue_winking_eye:


I ran into the same problem (IC, not motherboard burning). Tried to get on the 107th server, had a green shield which turned to red after I got booted for failing the IC. Of all things, it was textures/empty that got me kicked. Tried clean and repair, but refuse to change my Saved Games\DCS setup. I like my configuration too much.

The IC really needs to be customizable on the server side, with file/mod whitelisting and blacklisting options.

1 Like