DCS: Su-25 Crash on Start

Team, looking for some assistance. A recent DCS patch (I can’t remember which) broke the Flaming Cliffs Su-25 module in my install. Every time I load a mission in the Su-25 (not the Su-25T), I get an instant crash as soon as I click ‘Fly’ after the mission loads. It didn’t effect any other modules. If I don’t click ‘Fly’, I can change views, move the view around, but the moment I click ‘Fly’, boom, crash to crashlog upload. I have the UH-60 and A-4 mods installed, but nothing else. I searched the other forums for folks experiencing similar issues, but nothing stood out.

Happy to upload the crash logs, if it will help. Thanks in advance!

This might be a little obvious so apologies in advance if already tried, but did you run that dcs repair?

I used it once a while ago for a weird issue and it cleared it up.

If that doesn’t do the trick, hopefully someone else ran into a similar issue and can help.

I didn’t encounter this when testing the virtual pilot body after the 2.8 update (so a week ago probably, once I got to this one?). I have the Flaming Cliffs 3 DLC from Steam and run DCS from Steam and in VR.

Edit: I was only trying the “Free Flight” Quick mission, so maybe other missions are causing the problem? I also have the A-4 community mod installed, but not the UH-60L since 2.8 came out.

Affirm, I ran the repair. I’ll probably through a crash report on the ED Forums along with a crash log and see what comes up. The thing that really stands out is that if I don’t click ‘Fly’ at the start of the mission, after the load screens, it appears to be working fine. I can change the view, zoom and scroll around, no issues. But, the moment I “unpause” the mission by clicking ‘Fly’, crash…

1 Like

Have you tried temporarily removing the UH-60 and A-4E mods?

1 Like

Yup. Removed the mods, did a full clean and repair. It’s just the Su-25. FC MiG-29 worked fine. I’ll throw a crash log up here, see if anyone can decipher the problem.

1 Like

Here’s the latest crash log. Tried all the FC modules, along with a number of others. All solid until I try to load a Su-25 mission.

dcs.log-20221204-011009.zip (590.0 KB)


A helpful member of the DCS forums found the culprit. The export.lua file for my SimShaker seat was causing the crash. I deleted the export.lua file and problem solved. DCS recreated the file on start, and everything worked 4.0 after that.


Thanks for getting back with the solution! Hopefully it can help someone else in the future :+1:


Thankfully, the other forums made it pretty easy to upload a crash log!

1 Like