DCS Syria map not showing (Via Steam)

Hey

I have bought the Syria map on Steam and it is nowhere to be found, even though steam says it has been added to my library.

Apologies if this has been covered before.

2 Likes

have you got the open beta version of DCS, the syria map is only on that at the moment… Oh and welcome to Mudspike

2 Likes

Thanks for that, I will check. I fear you must be right because it is not even showing as greyed out in DCS, for example, the modules that you don’t own, and then when you click on it gives you the option to buy.

Thank you for the welcome, I think I am going to enjoy it!

1 Like

I have this version DCS World 2.5.6.54046

Is this the correct one?

2.5.6.54046 looks like the right version number…I must admit I dont use the steam version, but have a look in game at the module section at the top of the main screen, you may have to download it from there.

Module manager is not available to Steam.

Check under Steam’s DLC tab and see if it is in the list. If it is, you should be able to right click and install it there.

Cheers for that Wes, it shows the difference between versions. :slight_smile:

I wanted to give a more thorough reply but I was grabbing dinner!

Anyway, if by chance the module is just missing it’s icon so far @Spikeyspud, have you tried opening up the mission editor or missions menu and seeing if you have it listed in there? Franze makes a valid point about verifying installation.

Has it finished downloading as well? The map is close to 50GB of data unpackaged so if you just bought it, you’ll be in for a wait depending on your download speed.

Have you tried to kill and restart steam?

Hey

I have even uninstalled and then reinstalled DCS on Steam and nothing. I am a bit frustrated with myself, to be honest, I used to be the one to sort stuff like this out now I do not have a clue.

this is the only thing I can think of … image
that you do have the Open beta version, if you click on the game properties in steam, then go to the beta’s tab and select open beta…

Thanks, I have just started a fresh install on a brand new ssd with the old drive disconnected. I have just found out I have been flying around for over a year with some of the settings in “game mode”. I have turned it off, and now I don’t have to struggle to take off from the carrier. It is like night and day!!!

2 Likes

Hey, thanks.
I have it loaded on my laptop and I have just clicked that, it is now downloading so lets see!!!
I will let you know, but I am very confident.

1 Like


:grin:

3 Likes

Ha, thing is I didnt know that I was in flying around in GAME mode!!

and you were SPOT ON, my friend.

Thank you so much, to you and everyone who helped. There has been no " here we go againg, FFS read the thread or do a search"…just good, well intentioned help.

YOU GUYS ROCK

6 Likes

Cool to have new member!
Welcome and glad your sorted it out.

See you around. :+1:

2 Likes

Clearly Windows needs a SIMULATOR mode.

GAME mode, pfffft… :wink:

2 Likes

No problem, hope you enjoy syria :slightly_smiling_face:

1 Like
© 2020 Mudspike.com | Articles Website | Forums Rules & FAQ