DHCP lease problems...

Since we got fiber optic internet, I switched WIFI router to take advantage of the speed increase.
I got an ASUS RT-AC1900U.
All of a sudden I have trouble connecting to the WIFI network.
The router use auto IP assignments, and quite frequently, the wrong IP is issued. A DHCP Lease renew works on all the Apple units by clicking «renew lease». On the SimBox PC I have to do the ipconfig /release /renew a couple of times before it’s assigned a useable IP.

As this has nothing to do with building controllers or simulators, it’s not my area of expertise…

Anybody know what’s wrong with my WIFI network?

Does the simBox PC keep the same IP address the entire time it is on? If so the quick solution is to just leave it on.

Regardless, even with a IP that is assigned each time a device is turned on (from a completely off state-i.e. joins the internet) that process should be automatic.

It has been a while since I have had to reconfigure a router, so I could be out in left field (American for “totally wrong”). The way I remember it is that when a new device-PC, iMac, iPad, etc-comes on line with the router, the router gets it’s new IP from your internet service provider (ISP). I think there is a “front end” and a “back end” to that…an IP inside your LAN and an IP the ISP sees…cannot remember how that works.

So…maybe sign into your router and see if there are any settings that will fix it. :thinking:

1 Like

The router should assign IP addresses to any unit that connects to the WIFI, and it does. It’s just that an IP starting with 10.xxxx is assigned, when it should be 192.xxxx. Flushing the DHCP a couple of times fixes it, and a correct IP is assigned.
But why it happens in the first place, that I would like to know…
I have logged onto the router, and it has settings… Oooh boy, does it ever have settings!
If only I knew what they did. :wink:
I mean, I can set up networks and passwords, but that’s about it.

Sounds like you have 2 devices on your network giving out IPs. That could happen if you connected your router to wireless access point via a LAN port making the WAP act as an access point instead of a router. How is your WAP connected to your router/modem?

So your choices are connecting your WAP to your LAN via the WAP’s WAN port (Internet port), or to assign your WAP an IP and disable its DHCP server.


Aaahhhh… This rings a bell!
The Fibre optic cable modem has a router. It sucked, so I turned off its WIFI services and hooked up the ASUS router. I’ll log onto the modem again, and have a look.

You should be able to disable the DHCP on the router you don’t want giving out IP addresses.

This video may help if you have problems?


1 Like

What he said. :grin:

WiFi speeds being what they are now, I went with my ISP’s cable modem / WiFi router. In the days when that wasn’t so, I used to connect my Flightsim PC with CAT5 (to ensure connectivity and speed) …and some other things were CAT5…for a while I had a non-WiFi router plugged into my ISP’s cable router/modem…and remember something about ensuring I had plugged in the proper ports (another CAT5) between the two.

I have a similar setup, with ISP modem/router and my own wifi router. I had to put the ISP modem/router in bridge mode, and then have my wifi router take care of DHCP…

I’ll to totally dumb and say… Have you checked if there any firmware update?
I had a very similar problem in the past and solved it that way.

This is evidently totally above my level…
Yes, firmware has been updated.
That video about setting up a second router didn’t help.
My modem/router has IP and a DHCP range of 64-253.
I have no idea how I should set up the ASUS router to integrate to the modem/router.
I tried disabling DHCP server on the ASUS, and set its IP to, but that made it totally inaccessible and forced me to reset it.

After some googling I have found out that this is called a “double NAT” problem. As some of you mentioned, there are two “competing” IP addresses. Some modem routers can be set to a bridge or passthrough mode, effectively reducing it to a regular modem. Mine can’t…
The other option is to set up the WIFI router as an Access Point. Guess I can try that.
Not very impressed with my ISP who supplied this modem, with crappy WIFI speeds and no option for using secondary WIFI routers.