Disable full screen optimisations

For a while games I’d played ages ago with a lesser graphics card and RAM had been performing poorly on newer hardware (iL2 Sturmovik for example I was getting around 25-35fps) and I had no idea why. I’d stopped playing them but I read something on a forum about someone having FPS issues and someone said to check that ‘Disable full screen optimisations’ was checked in the compatibility tab for the games .exe. Thought I’d try it and it gave me back the FPS I used to get, iL2 is back up to 50-60fps (which is great for my old PC) and given me a boost in all games including DCS.

I don’t know if this was activated in an OS update but it’s great to get back to good FPS.


Yeah, I’m becoming more and more suspicious of any built-in Windows ‘optimizations’. I tried the HAGS thing with the new drivers. Something just didn’t ‘feel right’, after tweaking other things. Turned it OFF and things smoothed out again. This is in DCS.

And Hyper-threading! Had it off for like two years (on advice from the ‘Internet’). Just for grins, while I was exploring the above, I turned it back on. Another, though again slight, improvement. Now, none of this may help anyone else’s system, at all. Seems you just have to experiment.

1 Like

I didn’t even know that option was there and it’s turned on by default, it’s supposed to be better. Maybe with a really fast system? I don’t know. Makes you wonder, as you say what else is on or off and I don’t know lol

A lot of this is related to Windows 10 “Game mode”. YMMV when it comes to whether a given game will work better or not, but my guess would be–big name AAA game, it could help, niche title (like our sims), probably won’t and could even hurt.

© 2020 Mudspike.com | Articles Website | Forums Rules & FAQ