Does my motherboard have an infected BIOS?

Hey Guys,

I am wondering if you guys know of any programs that can sniff out a UEFI/BIOS Infection that can scan for Rootkits and such…

Now I have tried TDSS and MalewareBytes Rootkit and they both say I am clean but I still think there is something a miss with my PC Infection wise…

I don’t thing it is a regular malware/virus as I have done mulstiple scans with multiple antivirus so that should be good… I just have a funny feeling somekind of infection is in my BIOS chip, I tried to see if I could remove and replace the BIOS chip but it is soldered in and I have no way to do that or know anyone who can…

I am just trying to find a scanner program for Virus in the BIOS… now I have flashed it with new 2.10 BIOS from the 1.90 and it still seems something wierd going s on with my PC.,.

I would like to know if any other such programs existas I do not want to go on without running some more thorough scan for Viruses in the BIOS/UEFI… so any such programs please let me know…

OK I found “ESET” has a UEFI scanner I will try that and report back…

EDIT: Well it had a good section to scan many things and it came back Clean. I am guessing maybe there is a hardware issue as my PC takes it’s time opening programs so maybe I will have to test more of the components.

I did a while back and that checked out so I am not sure what is causing the hesitations in opening the programs…

I will see what the Oracle has to say… thnx guys.

1 Like

If you can find a replacement bios chip, the actual soldering part isn’t that difficult for a true electronics repair shop.

I once got infected with a Cryptolocker variant. It wasn’t pretty, my bios got infected as well.

Good news is that after formatting your harddisk, flashing the bios with an earlier version, then again with the latest version and reinstalling all software is always an option to get rid of something like it.
No soldering needed. :wink:

1 Like

Erm, is it really just a funny feeling or do you have any hard evidence? This is some drastic stuff you are bringing up here and I wouldn’t do that just on a whim. Maybe you should start with describing exactly what led you to believe that your BIOS is compromised.

1 Like

Well like I said it was just a feeling no hard evidence. I did the ESET scans and they came back clean as a whistle. so maybe just my mind playing tricks on me I guess.

I am guessing if there was something ESET would have found it. But I did reflash the UEFI and that should have eliminated the Virus if there was one I guess.

Guess I will worry about other things as I think this problems is solved as of yesterday with the ESET Scans…

I’d start searching more on or above the operating system level, like is your RAM full and maybe your OS has to swap, or is some service bogging down IO or the disk where the program is installed. Could also be a kernel update, the mitigations for the newest set of speculative execution attacks are out and those come with a performance hit. In the case of DCS, since one or two updates back load times have become significantly longer by itself without any fault of my system, etc. There could be lots of reasons for what is happening. I don’t want to sound condescending, but if you haven’t actually taken measurements of the load times, it could also be just a product of your imagination. Our brains just work like that.


Well Like I said I ran some ESET Scans in the BIOS and such and it did not find anything so I think this is a solved case.

I origianlly was just asking for a Program that scanned the BIOS. I found one ran the scans it found nothing so like I said before it was probally just my imagination…

But you said there was some updates I guess to windows and that could be causing the delay in boot time…

OK I was just having some wierd things happen. I was transferring files fro my HDD to a USB Flash drive and it kept fqailing and I would get an error saying the drive is not there.

The files were transfering fine for a little time and then it would error out. I did not get a USB Disconnect from Drive J, I disconnected and reconnected the USB drive and tried transfering the files and voila I would get the file to stop transfering and an error stating the drive is not there…

I then disconnected from the internet and voila files transfered without an issue… OK now if that is not a virus causing that then what would cause that to happen while connected to the internet. and then be fine when I unplug from the internet…

Another funny thing is I have a Sanitize drive tool in BIOS but ever since when I thought it got the BIOS infection it has not worked. even when I reflashed BIOS 3 times… I can run Parted Magic and erase the M.2 SSD then with nvme erase tool which works fine just not the tool in my BIOS…

OK I am totally unsure what is going on but at this point I am unsure what even to check as I ran all sorts of stress tests and Benchmarks, besides the userbenchmark that scored less for the SSD and Memory the Stress test check out ok as well.

Here are my system specs incase you want to know:

  1. Intel i5 10700K @ 4.8GHZ
  2. ASRock Z590 Phantom 4AC.
  3. eVGA 1070GTX 425.06 drivers. I use them as I use a 3D vision setup with VR and Helixvision.
  4. SoundBlaster Z Latest drivers.
  5. Noctua DH14 Heatsink single fan.
  6. PCIe USB card 4 3.0usb’s
  7. Corsair TX850M PSU.
  8. Thrustmaster Cougar and 2 MFD’s
  9. HP Reverb G2 VR Headset.
  10. Razer Blackshark headset 2.0.
  11. Buttkicker Gamer 2.
  12. Win 10 22H2 fresh install 1 week old all updated through Windows update.
  13. G.Skil Trident Z 32GB Memory OC to 4000 from 3200.

EDIT: Well it might have been an issue with my USB devices I had narrowed it down to a USB Issue. at least I think it is?

I will have to take a closer look at the usb devices Perhaps that has been my problem all along… haha!!

well from the looks of it might have been my HOTAS Cougar. Luckily I have another stick and swapped it out we shall see how it goes…

EDIT: well that seems to have been the issue that progressively got worse over time… maybe all this time that was causing the little glitches here and there… I guess no need to reinstall Windows right now the upgrade to 22H2 seemed to have went smoothly as far as an upgrade like that goes…

I will keep my eye on it but now the issue is how much longer will I be able to use my Cougar as that was the last other stick spare I had…

Thank you Guys.