FPS capped to 64 / 50 when unpaused

Here’s a though one for you.

I recently discovered a strange behaviour in my DCS installation:

My frames per second are capped at 64 or 50 fps (it’s either one of these values, usually it starts with 64 when I launch DCS the first time after a reboot but it changes on the second time I launch DCS without touching any configuration in the game or windows).

Here comes the kicker: when ever I hit pause, frames soar up to the limit which can be controlled by the usual suspects (V-Sync, maxfps settings in graphics.lua, Nvidia Control Panel, etc). With pretty low settings and no V-Sync my system can reach up to 170 fps when I pause the mission.

My specs:

  • i7-7700 (no overclocking)
  • GeForce GTX 1070 (no overclocking)
  • 32 GB RAM 3200 (running with mild 2133 MHz)
  • Win 10
  • G-Sync compatible Monitor Samsung C27RG50 (running 1080p @ 120 Hz in Windows; capable up to 240 HZ) connected via Display Port

Here’s what I already tried with no success after reading some weird threads in the ED forums:

  • Switching V-Sync on and off in Nvidia Contol Panel (NVCP) and in game
  • Disabling G-Sync on the monitor hardware controls and in NVPC
  • Change multiple settings in NVPC profile for DCS, including:
    • Low Latency Mode (On/Off)
    • Max Frame Rate (tried 120 fps and off)
    • Power Management Mode (Optimal Power/Prefer Maximum Performance)
    • Preferred Refresh Rate (Highest available/Application controlled)
    • Vertical Sync (On/Off see above)
  • Changing the refresh rate of the monitor in Windows to 60/120/240 Hz
  • Removing/commenting maxfps line in graphics.lua (it was still set to default value of 180)
  • Repair DCS
  • Activating/deactivating Geforce Experience Overlay and also trying to start video screen capture (formerly known as shadowplay)

Other games a working as expected. DCS as well but only while paused. I came to the conclusing that this must be a software bug with my installation.

Any ideas are very much appreciated.

Is this across multiple planes and missions?

Yes. I tried several Instant Actions (F-14, Su-25T, F-16). The cap limit also is visible in multiplayer.

1 Like

You running Stable or open version of DCS? It maybe worth downloading @SkateZilla updater and switching versions to see if the FPS bug follows.

1 Like

I run OB. Since there was a recent merge into the stable branch I’m afraid there will not be a big difference. But I will give it a try tonight.

1 Like

It’s the same in the Release branch. :neutral_face:

I recall being capped at vsync values a patch or so ago - so 60fps or half rate 30 for my monitor, despite all those setting being turned off.

It was a DCS bug at the time with the newer Nvidia drivers, I have not noticed that in the latest patches though.

1 Like

Thanks, I also upgraded to the latest driver from November. I think I used something from September before with the same issue.

Is there any recommended version for the Nvidia driver to roll back to for DCS?

I am currently on the latest - 457 something iirc?

What version of Win10?
You can search WinVer in the windows taskbar search to quickly pull that up.

Yes, 457.30.

Windows 10 Version 2004.

Ok… I found it.

I renamed my Saved Games DCS folder and the issue disappeared.

Further investigation revealed that I had some 2000 lines of lua code in the /Scripts/Export.lua from my Helios integration (third party touchscreen software for aircraft panels).

Since I don’t really use my touchscreen anymore I decided to remove the lines instead of troubleshooting this code. Call me lazy :stuck_out_tongue:

3 Likes

+1 for our debug checklists

2 Likes