FSX Debug help

I’m having issues with my Flight Sim Labs’ Concorde X install into the Steam Edition of FSX. I run the installer per the manufacturer’s directions, verify the necessary dll (FSL_CONCX.DLL) in the [Trusted] section of FSX-SE.cfg, but the .dll never loads. The result is a Concorde shell - no gauges, no working landing gear, no clickable switches, etc. Completely unflyable except for external screenshots, but I can’t even light the reheats.

The advice I’m getting on their forums is “Are you sure you’re checking the right file?”, so I’m reaching out to my fellow FSX’rs here:

If a .dll doesn’t load even though it’s in the [Trusted] part of the FSX_SE.cfg, what would you do to troubleshoot?

Do you have the latest Concorde X - I ask because they seem pretty active for fixes and the changelog mentions the Steam version too?


Yes, I do. My problems started with the “stable” version of 1.31, and I’ve installed version 1.32, hoping to see better results. No joy.

Here’s a recap of my issue:


[quote]No crashes, no errors, just no “Loading Resources” bar, no gauges, no gear, just an empty, soulless Concorde husk.

  • I’m running Windows 7, 64bit
  • I have FSX (boxed) installed on my C: drive and FSX-SE on d:
  • I have reinstalled FSX-SE and Concorde X (now 1.32) several times, following the handy guide here: http://forums.flight…ion/#entry47456 (except for the FSL Spotlights steps - I don’t own that product).
  • I reboot my PC after each install attempt.
  • I’ve verified that the FSL_Concx.dll file is present in FSX\SimObjects\Airplanes\FSLabs_BAe-Concorde
  • I’ve verified that there is an entry for FSL_Concx.dll in the [TRUSTED] section of fsx_se.cfg at AppData\Roaming\Microsoft\FSX-SE
  • I’ve verified my anti-virus (Avira) hasn’t quarantined or made any reports on FSL_Concx.dll. I’ve tried installing Concorde X with the real-time protection turned off.
  • I have not installed any other addons to FSX-SE. My dll.xml looks almost exactly like the one posted earlier in this thread.
  • I have run Concorde X in the boxed FSX version on this same PC with no unexpected issues ( http://www.mudspike…cross-the-pond/). It’s only been the Steam version I’m having issues with.
  • I run the default Trike mission EVERY TIME I start up FSX-SE.

This has been a rather baffling experience.

Hmm. My FSX-Foo is poor, so just random advice in-case it helps:

  • Try the Steam client elevated, i.e. run as Admin. The funny installer for Concorde X might have marked the .DLL as not from LOCAL_MACHINE so that might help.

  • For anything file related or for dynamic library dependencies, something like procmonitor gives lots of system info. You can use to to capture events on what files / registry keys are being asked for by an app. If you set up enough filters and start/stop the capture at the right time (i.e. when FSX is starting up) then you can watch what the FSX process is looking for - it sometimes helps find typos in path names i.e. a FILE_NOT_FOUND etc.

(it’s a weird app, so I’m happy to do a quick intro-steps thing if you like)

  • Can FSX and Steam-FSX run side-by-side? I’m not sure, but it might narrow down as you might be more unusual if you have both installed. Something like simconnect might be confused etc.

Running Steam as admin didn’t help.

That processmonitor is pure magic, however.

Now to understand why FSX is looking for FSL_SimConnect_Ldr.dll in the wrong place. If I move the .dll to any of the paths it’s searching, FSX crashes.

It might just be another name for a file, as some do versions by name.

The Tools / File Summary shows all the ones accessed or not.

I uninstalled Concorde X and FSX-SE, wiped every reference to them in my registry, and reinstalled. Seems to be working now, although the FSX main GUI is hosed after I exit. It’s centered at the bottom point between my two monitors - seems Concorde X in FSX-SE doesn’t like fullscreen on multiple monitors.