Help. I can't download a dcs module


I recently purchased the 190 module for dcs, however when I attempt to install I get an error message saying that version is not available.

It seems the game does not recognize an internet connection??

Any thoughts? My game is updated to


Try a repair, then try to install again.

Thanks sobek. I’ll give that a go :slight_smile:

Btw. are you on open beta or release channel? It looks like your module installer is looking for the current open beta version. Could be a potential bug with the module installer.

sobek, I"m living on the simming edge with the open beta :slight_smile:

This is weird, any luck with the repair?

Giving it a go now, had to break for xmas shopping, bloody rl getting in the way :slight_smile:

hmmmm, when I try to do a repair I get the same error message, that the current version is not available

I can’t reproduce your problem to be honest. I think you should write a bug report, hopefully c0ff can have a look at your updater logs and figure out what’s going on.

You could also try to switch to release and back to open beta, but that would see you download ~24gigs of data if it even works.

Could it be that antivirus or some kind of firewall started blocking the updater process? Could you post a screen or transliterate the exact error message?

Yes, I’d prefer to avoid a large download as I’m data transfer limited

I like the idea of the firewall or something blocking and this will be my next step :slight_smile:

1 Like

I know it’s silly- but… you tried Skatezilla’s tool for updating/maintaining DCS?
It’s heaven sent…

1 Like

No I do not use Skatezilla’s tool. Might have to komemiute :slight_smile:

I noticed in my firewalls settings, I have four DCS updaters listed. Not sure if this means anything

1 Like