Help needed creating videos in DCS

How are all of the very nice videos we see on youtube actually created? I would like to try my hand at this. Many Thanks

If you’ve got a nvidia card, I’ve had nothing but good experiences with shadowplay.

ATI has their own version of this, but the name eludes me.

  1. Get video capture software. If you have an nVidia card, you should already have ShadowPlay, which does a fine job of capturing gameplay video in .mp4 format. FRAPS is another popular option, but costs about $40 USD. I have both and use each in their own way.

  2. Get video editing software. I’m not sure what free materials are out there, but I got Sony Vegas Movie Studio on sale a while ago and am very pleased with it. I’d like to get a full version of Sony Vegas, but the cost is huge.

  3. Get a YouTube account. Comes free with a gmail account.

  4. Make videos. This is the part that’s hard for me. I don’t like to upload just raw video of 45+ minutes of gameplay, so it takes a LOT of editing, which in addition to the tool and technical knowledge of how to edit the video, you have to know which clips go together in which order. I’m not good at this at all, but there’s a lot of examples out there, bad and good, for you to check out.

Share what you make with this crowd and you’re sure to get some gentle feedback!

Hey thanks near-blind and EinsteinEP for the info on Shadowplay. I set it up and tried to record a short session in DCS but no luck. I used the Alt+F9 option to start and stop a recording but it didn’t record. Also within DCS the camera and status icon do not appear. Close but no cigar. Any ideas would be appreciated.

So DCS 1.5/2.0 uses some odd borderless windowed mode that shadowplay has trouble with. You can get around this by hitting alt-enter, which seems to bring it into a normal full screen mode. The caveat here is if you alt-tab while recording the game will default back to the borderless windowed mode, and shadowplay will stop recording.

@Fridge and myself have also noticed some vertical tearing when in full screen, but it’s random when it will or won’t show up, and can usually be solved by alt-entering a few times. Hopefully shadowplay releases an update that will fix this at some point.

I had this issue too - turned out you have to keep the Geforce Experience app running for the shadowplay stuff to work

. . . and here is a video to prove I got it working :smile:

I use the “Record desktop” option to good effect.

Very nice Video Krautwald. You are an inspiration. I will keep a it.

1 Like

Before I go further, I want to honestly say that as I have perused the forums here, and now with my post about how to record, I think that this forums is one of the best in the flight sim world. Everyone is courteous and helpful. So, thank you all for that.
Now, on to my progress, or lack there of. I have GeForce and Shawdow play open and minimized. Alt+ Enter only causes my screen to flash with no changes evident. I am trying to record a live flight with Alt+F9 to start and stop.
I did notice in the setup process that the location for the file to be saved does not match the location on my C drive.
Users\Owner\Videos is the the save location in GeForce but the matching location on my C drive is.…My Videos. I cannot change the location in the app to any other.
So, as anyone gets the time and the inclination to give any advice, I will be looking forward to it.
Also, I have “allow desktop capture” checked.
Many thanks

1 Like

have you turned on the status indicator? It should come up when you press record and change again when you stop the recording. Might help with troubleshooting

Me too. Note that if you do this, look for the recordings in a /Desktop/ folder

Does anyone of y’all use ShadowPlay and multiple monitors?
Everytime I try it I get a BSOD…

I am using “CamStudio” at the moment. (I seldomly record but it seems that one does the job once the codecs are installed)

Well, after putzing around some more, ShadowPlay is now working. Thanks everyone.

1 Like

Two monitor user here. Works fine. No BSODs.

Not sure if it was mentioned here, but, with DCS doing the ALT-Enter to make sure you are in full screen (known bug with DCS not starting in full screen even though its checked). Doing this you dont need to do the capture desktop option.

The shadow time option is awesome by the way, being able to record the last 4 minutes at anytime is very cool if you want to capture something that just happened while gaming… comes in handy when I go on a tear with a vehicle in Heroes and Generals :smile:

Thank you, Sir. All seems to be well and I am recording however after trying what you mentioned, Alt-Ent changes nothing and capture desktop needs to be checked in order to record. A small thing and I can live with it.
What I am curious about now is the recordings do not have the same quality as “in game.” They appear to have a slightly grayed out appearance to them. I haven’t been able to sort that one yet.Video card setting maybe?
I also installed the Sony Vegas Pro 13 software.YIKES!
Many thanks.

I don’t know the exact cause as I don’t use shadowplay nor Sony vegas. But some basic troubleshooting is to first check the settings. Are you recording on full resolution? Some recording software out there allows you to record at something like half the resolution you are playing on. By only recording every other pixel you save resources and space but it is a lower quality. Second maybe, are you recording at a decent bitrate? The recording software doesn’t have time to compress the footage you record, so you’ll need a lot of space. I think the minimum bitrate you need to get decent quality is about 50MB/s. I think I had my software running at about 133MB/s. so 8GB for every minute of footage. make sure your HDD can keep up with that pace, or use an SSD. Lastly, some video players like windows media player may have issues with such large files and display at a lower quality than true. Try to compress the footage with your editing software, don’t use the preview, just let it compress to a more reasonable bitrate than the raw recording. As for your gray-out issue. There might be a function called “capture lossless RGB” that should give better colour.

Hope I helped atleast a little with your issues :smiley:

turn up the recording bitrate in shadowplay - I use 90