How to start to fly in DCS World

I have loaded the DCS World and set up my x52 Pro for the F-18. However, when I load the game, I get to the training and the phone is there, but I can not use the keyboard or x52 when I press the space bar as instructed nothing happens. I can not look around or move the plane. I tried every key and nothing. Checked the x52 profile and see the assignments are there and the keyboard controls are there. but nothing. can anyone aid me and how to get started running the training?

2 Likes

That’s strange. It sounds like it has paused. The training missions often begin in active pause mode, not letting you click anything until you press space. But you said that you tried that, so not sure what’s going on. How about trying an instant action mission. Say an easy one for the Hornet. Not at my gaming PC, but there are usually some free flight or takeoff missions.

BTW, welcome to MUDSPIKE.

1 Like

Thank you for answering. I have tried to run other missions. Just to check if it was my system. But I get nothing. I downloaded the F-16 and got the same thing I cannot look around and the system will not let me do anything. I cannot change views. The keyboard doesn’t work, and the controller does not work. I when in and changed the control buttons but that did not help I still can not fly any plane in the DCS World. What am I doing worng?

So, the condition is universal across missions. One more item to check, all of the missions begin Paused. There is a Fly button, but you also have the option to hit the Pause/Break key. I hate to ask if you are doing this, but let’s begin at the ground level.

1 Like

Yes I tied the pause/ break key nothing happened. I tied every key and rebooted the system so many times I lost count. I just don’t get it I have to be doing something wrong or it is some little thing that I have missed. Everything works fine in Steam FSX but the DCS world just doe not go.

2 Likes

When you press the keys in the setup screen or move the joystick axis, do they register

For example if you press G does it jump to gear up/down and on the axis setup can you see the white line move corresponding to the stick position?

If you push left ctrl and C in game can you click any cockpit switches with the mouse?

1 Like

Yes, When I press G in the setup profile screen it moves to Gear Up when I press the button 11 on my joy it moves to the gear. I tried to save teh profile and go back in the game, but I get the same results. nothing changes. If I hit the F10 or F11 key sometimes it changes to a different screen and will let me hit the Esc key to get out the game.

1 Like

No to teh second part of your question I get nothing when I hit ctrl C in game. My version of DCS is 2.7.10.19473. Do you know if there is a later version. or of a way I can uninstall teh DCS and re install it.

1 Like

I would try and repair the game first.

The easiest way is to download the “skatezilla launcher app” let me find a link for you. Its much easier to see any problems if you use it

It has many useful functions that will help. You can update and repair directly as well.

You need to give it the location of your dcs install and saved games folder to start it up

Thanks, I will try it and let you know have thing go.

Oaktony, do you mind saying what your system specs are?

The combination of the X52’s profiling software and DCS’ control setup can be confusing . I would first try keyboard-only control mode . Disable SST ( i think that is the name of the Saitek profiling software ) in Task Manager . Then open DCS and check the control assignments in the keyboard column . Then try a free-flight instant action mission . If that works , it is time to check the SST profile . Note that you must select a Saitek profile to load before flight .
Also , it is possible to assign controls in “sim” mode , and then fly in “game” mode (or vice-versa) which will also cause control problems .
Finally , if you’re flying in VR , be sure you don’t have a “Window out of focus” message in the upper part of the view .
That will disable all control inputs . Alt+tab to bring DCS back in focus .

1 Like

thank you for your reply I will try that as soon as I get teh system reloaded. I uninstalled DCS and rebooted my system. The system is now downloading the new version of DCS. I will let you know how it goes, it may take up to six hours for the system to re install…

My system is a tower CPU Intel I5 4950, Socket 1150 LGA CPU 3.30 Ghz, Mem DDR3 32 GBtes
Graphic card NuDia G-force CT730 Mem 4GByte DDR3 Bus with 64bit One Monitor using X52 Pro and Standard Keyboard. A mouse with c: drive is 1 TG and D: is 4 TG Window Pro 10 64bit

I hate to be the barer of bad news, but IMHO that’s your bottleneck right there. I think that when the sim loads, it doesn’t have enough GPU memory to run and locks up. ← my layman’s understanding.

I believe that the minimum spec GPU that you can run is a GTX 760. Anyone else want to chime in?

https://www.digitalcombatsimulator.com/en/downloads/world/stable/

2 Likes

Sad but true. Somebody get this man a GPU, stat! :ambulance:

So the problem is I need a stronger graphic card. The one I have is not able to run the game? Can you tell me the best one to buy to get the job done? Or does anyone have a good one?

Assuming your monitor has no more than 1920x1080 (or x1200) pixels:
GTX 760 is the minimum and GTX 970 or 1060 should be good for medium settings. If you want to set higher settings, you could get a GTX 1070 or RTX 3050.
But I wouldn’t go higher than that on the GPU with this system on 1080p resolution

1 Like

Freak, I see that newegg has the RTX 3050 for $380. It’s PCI Express 4 though. I think most 1150 socket mobos are PCIE 3. Would that card be backward compatible?

Ooh good point, it might be bottlenecked by the lower bandwidth of PCI-E 3, better to go for a 900 or 1000 series then

EDIT: quick Google shows no big performance dip when using PCI 3 instead of 4 for the RTX3050:
https://www.club386.com/pcie-scaling-on-nvidia-geforce-rtx-3050-examined/

I recall reading that the RX6500 does suffer a lot from running PCI 3 (since it has less lanes) so don’t get that one

2 Likes
© 2021 Mudspike.com | Articles Website | Forums Rules & FAQ