HP Reverb G2

It’s about 12.5% better, maybe? :frog: About 8% of that is nicer audio, although they are open earphones if you don’t want to wake the cat up.

If you have prescription lenses you might have to buy them again, as I think the lens changed shape.

I changed because my G1 died, but if it hadn’t I don’t know if I would spend the money.


For me, coming from an Odyssey+, everything was better. However, the build quality of the G2 is average; cheapest hardware they can put in it, perhaps minus the lenses?. That has been my experience with HP hardware for the last 25 years. Was hoping the VR headset might be better.


A nice surprise for my G2.

I got the G2 more than one year ago with the v1 power cable. I had issues time to time (connecting errors, intermittent audio…) though restarting and some fiddling usually got it straight.

One day (few weeks back) I decided enough was enough and got in touch with the retailer I bought it from (Bestware.com - located in Germany) to ask for a replacement cable. The thing was I was already out of the HP warranty period which lasted for one year. I thought in the EU we got a warranty for two years so I was a bit surprised.

Anyway, I asked nicely the customer service in Bestware whether they could get in touch with HP and deal with my request and…
…they actually did. They said that HP would provide the cable nonetheless, only it would take some time (in terms of weeks).

Today I got a package :slight_smile:


(I hope it works. If not, you will hear back from me… EDIT: It does :slight_smile: )


I like the new cable a lot…a big improvement on the first version. The on/off switch on the box saves a lot of hassle when the headset needs to be reset.


well I noticed the new WMR Interface works better then the old one did I had installed my G2 and had no issues like before, I even have v1 of the cable.

I also would like to say in DCS I can only muster the lowest setting on the G2 for resolution. I had gotten to 30% but then I ran the instant action in Syria and needed to lower the setting for a better overall usage…

I think the res is like 1440x1400 or close to it. what you guys run at. I am on a 1070GTX FTW… would love to find a 2080ti well if I had the money that is… :wink:

1 Like

Oof that’s rough. Are you using the vrperfkit to squeeze some more pixels out of it? You can get about 25% more pixels for the aame performance using this:

I would suggest going into the yml file and using NIS scaler, setting renderScale to 0.67, then setting DCS to 1.5x more pixels in SteamVR.
If you also prefer instruments clarity over smooth terrain outside, up sharpness to 0.8 in the yml.

Then copy both yml and dll file into DCS’ bin folder.

Repeat the copying after each DCS update

SteamVR instability has cropped up again. I’ll be flying a mission and it will freeze, often with the sound looping. I take off my G2 and see that there is a message on the SteamVR icon that it has stopped, offering an option to restart it. Anyone else having this or know the best way to troubleshoot?

@Freak, I tried this mod and set the rez in Steam VR to 30%, I think it looked worse then at 20% and performance suffered a bit at least in my experience…

I will just keep it like it is and wait until one day when I can get a better video card… for now DCS is at least playable and don’t look to bad well at least to me…

Thank you for the heads up on that program thos to bad it did not work out for me… I guess YMMV…

1 Like

I get that occasionally as well . No idea why . Waiting on a Steam fix .

1 Like

I should be flying DCS Online tonight I will see if I get any freezes or CTD’s and such. I was playing earlier and was running into RAM issues. I have 32gb but the game was using upto 31.9gb which made the game a slideshow…

That was a mission in Syria instant action but I think they are still having issues with the memory not being cleared between missions.

I did try and find the same memory I currently have but no luck and 64gb of RAM cost about 250usd way more then I can spend currently on wants…

Well I flew for 3 hours and not a single freeze or CTD to report… Do you guys Overclock your CPU,GPU?

Barely. I did increase my RX6800XT’s min clock speed to just a little below maximum (stock) clock speed, as well as increasing the fan curve and power limit. This should theoretically make gameplay smoother, though I have not measured it.

I also did an overclock on my Ryzen 5 5600X, but the increased clock speed made very little difference. What did make a big difference, and I highly recommend if you have a good cooler (not the stock AMD cooler), is to set the PBO power limits to “Motherboard”.

If you have Intel, depending on which generation it is, you may also want to up the power limits.

1 Like

You do not need 64GB of RAM to play DCS.
8GB is not enough for complex missions, 16GB is good for most cases, and 32GB is safely enough for now. With your current hardware, I would first upgrade GPU if anything. Unless your CPU is very old maybe

That’s a negative. I’ve tried updating drivers, SVR, beta, non beta WMR for Steam, and using default settings all the way around, but still getting a stoppage in SteamVR in DCS about a third of the time. Usually restarting SVR and DCS solves it, but really aggravating when doing cold and dark, plus setting up radios, navigation, etc.

yes really wierd have you checkedd your systems for Stability with a stress test? Also You could try to verify files in Steam sometimes SVR gets corrupted when it updates itself…

Besides and unstable system not sure what else it could be maybe a conflict with some 3rd part software?

Did you check the Windows Event logs for anything useful at the time of the crash?

Yeah, good call PB. I had looked in the System log, but forgot the Application log. I rebooted my system, started DCS via Skate’s Updater, jumped in the UH-60L in the PG quick start mission Cold and Dark. Began working through the startup checklist and when I move engine 2 PCL to idle, SteamVR and DCS crashed. Found this. Looks like the vrcompositor.exe is the culprit. Not sure exactly what action to take, but at least I know what is faulting. Doing some web searches now.

Faulting application name: vrcompositor.exe, version:, time stamp: 0x622bb880
Faulting module name: ucrtbase.dll, version: 10.0.22000.1, time stamp: 0x00e78ce9
Exception code: 0xc0000409
Fault offset: 0x000000000007dd7e
Faulting process id: 0x3c10
Faulting application start time: 0x01d8369aa6335d26
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64\vrcompositor.exe
Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
Report Id: b7824267-e9b9-4155-8b48-aef5f7579dc7
Faulting package full name:
Faulting package-relative application ID:

Edit: Found this reddit post, which is similar to what I’m seeing. Going to disable WMR motion reprojection to see if that helps as it did with this person.

1 Like

So far, that seems to have been the issue. Happy Black Hawk camper again.


Try starting DCS from within SteamVR home, or the WMR home. This has fixed this problem for others.


Looks like a classic software bug, Chipwich.

Whatever is using the library ucrtbase.dll is doing something it should not.

Are you using any non-production ready beta software? :smiley:

If it’s not gone now you could file a bug report, a dev with a debugger might be able to find the code line that causes this.

1 Like