IL-2 BoX control issues

So, something strange I just noticed tonight: my CH rudder pedals aren’t working in IL-2. This had me scratching my head since the last time I played, everything was fine. Throttle was OK, stick was OK, but no inputs were getting through from my pedals. No matter what I did, IL-2 would not recognize inputs from them. So I tried a refresh of the controls file and now the only thing that works is my CH stick! I read that sometimes the Steam controller options can cause issues, so I turned those off but IL-2 still won’t un-eff itself. Everything is good in control panel; inputs are clear and shown. Works fine in DCS.

Any ideas?

ETA: I restarted my computer and it suddenly decided to work. But all my IDs are all reset now, so I have to rebind things.

Ugh, sucks when that happens.

I have this with my MFG pedals sometimes, but a restart often unducks the thing. I suspect my cheap Chinese usb hub is the culprit.

I had a problem like that in IL-2. Deleted the controller file and remapped everything.

That’s what I tried to do after I couldn’t get my pedals to work, but after doing so it only resulted in my stick being the only working input, with the throttle and pedals not working. No idea what was fixed by the restart.

© 2020 Mudspike.com | Articles Website | Forums Rules & FAQ