Losing my Controllers


#1

So this is an annoying issue that seems to be popping up with increasing regularity. Any thoughts/ tips/ ideas would be greatly appreciated.

My Warthog joystick and throttle seem to take turns dropping out every now and again. This only seems to happen when I start a script in TARGET, and it seems to happen with most of the USB ports that I plug things into. I currently have the stick plugged into a USB hub attached to a USB 3.0 port on the front of the case, and the throttle is plugged into a USB 2.0 port on the front. I’ve had to relocate my MFD’s through a couple of different ports before I’ve got them plugged into the ones they’re in now, because they were having issues with not being active in TARGET a couple of months ago. Not sure if this is a hardware or software thing, and I’m wondering if anybody else has noticed similar issues.

Motherboard is an Asus Sabertooth FX 990 R2.0
Case is a CM Storm Trooper


#2

Do the USB controllers power down…?
Do you know of the «allow windows do power down» setting in device manager?


#3

:musical_note: that’s me in the corner, that’s me in the spot… light, losing my controllers. Trying to keep an eye on you, like a hurt, lost and blinded fool. Fool :musical_note:


#4

Yeah…I think I had something similar when I used TARGET. You get more out of them using TARGET, especially the 3-way switches, but…I gave it up.

I have a similar issue wit FSUCIP and FSX…I switch out controllers–stick to yoke–and find a couple thrust axis have been mapped to my yoke…but that is not germane to your issue.


#5

They shouldn’t- disabled that setting when I updated to Win10, and just verified its3 still there.


#6

In my case my motherboard’s USB subsystem was the culprit. Everything else on powered USB hubs was fine. I was due for an upgrade, so replaced the mobo, processor, and memory. Problem solved. Upgrade and USB is problem free. FYI, I tried the usual troubleshooting steps like firmware and driver updates.


#7

Exactly what I was going for. There are few things more frustrating than running through the cold start for the Mirage or Harrier, waiting for the INS to fully align, taxiing to the runway, taking off, then finding out you have no pitch and roll control.


#8

Yep, already run through that dance myself as well.

Sigh… I was hoping I could wait a bit longer on the computer upgrade- paying for grad school and needing to buy a new laptop for that has put a dent in my play money until probably February or March…


#9

I sometimes unplug and re-plug the usb cable that connects to the (unpowered!) usb hub where my HOTAS is plugged into. DCS allows hotplugging controllers and will recognize it. Perhaps that could be something you could try?


#10

DCS recognizes it yes, but unless I’m missing something it seems to cause TARGET to crash, meaning having to exit DCS, restart TARGET, and rerun the script. Unless that can also be hotplugged?


#11

You may have mobo usb controller damage. I have had it happen a couple times, and I associate it with static. I have disciplined myself to touch my antistatic strap before getting on the computer. But when that damage happened it was always just the usb2 chip that got it.

My advice is to try a new usb2 powered hub for your flight stuff.


#12

Also there are powered USB hubs and there are powered USB hubs, went through a few before I found good quality ones, use Belkin 7 port powered USB hubs here, but if you have tried the windows trick of disabling USB power management then it might just be your motherboard as suggested.

Might want to take a look in Device Manager and make sure all is good there too USB wise.

Its this model I use that I dont think is made any more? but I have 3 of these hubs on the one PC to deal with my FS perhips, 12 Saitek FIP’s and other panels, Cougar MFD’s ETC.