Lost Ability to Use Mouse for F2 View in DCS

Starting about I month ago I lost the ability to use the mouse to slew my F2 view (or any other external view in DCS). I can use the numpad 7, 9, 1, 2, /, * but that’s it. All other mouse functions work fine. I can click the cockpit and manipulate the F10 map. Help appreciated. Thanks!

Did you just want to state this fact, or do you want help with fixing it? :wink:
Didn’t you erase all of your control bindings, recently? Was that when it happened?
Can’t you just bind the mouse to the external view controls again?

I thought the mouse bindings couldn’t be changed

I have had this happen to me before, I wish I could recall what fixed it.

Have you tried searching the module and the UI layer controls for “mouse” - there may be a keybinding to “enable mouse control” or the like that was accidentally hit when reaching for something else?


Pardon me officer, I didn’t realize my grammar was that bad. You can just let me off with a warning, right? :laughing:

It was “view horizontal” and “view vertical” in the axis settings. I missed it in part because the far-right “mouse” column is off screen in VR. It works now but slightly differently in that I have to double click the middle button in order to pan the view. But I got what I needed. Thanks!


Ok… Just this once. :wink:

1 Like