Missing Avatar Images Bug

A while back the forum software had a bug where it went crazy and got into a loop on importing some images for a post. We run a beta version here as I like to see the new toys (plus add our own) and we got bit. The bug was that a feature of this forum is that if you put a remote image in, like this:

,then it will go make a smaller compressed local copy of it and store it here, as remote images often break and gradually forums sort of fall apart over time.

What happened was that this broke and we ended up with 14GB of duplicate bad files mixed in with our ‘good’ files (excluding @BeachAV8R’s gif fetish). The bug got fixed and the database tidied up, but to clean-up our disk space I had to do some dancing to go find the bad files and clean them out (the server is small, so something had to be cleaned up).

This seemed to go ok this morning (hence our bit of downtime), but if you spot a missing image then please PM me. Before I ran the ‘clean up’ I kept a backup of all the old files, and while it isn’t easy to 1:1 find them, they aren’t completely gone.

I’ve noticed a couple of older avatar images are now missing for people, so am looking to fix up that. Alternatively, if you see your user pic has changed then you can upload again and it should be ok too. Apologies for that though. :expressionless:

1 Like

…and if your Avatar has changed to a cat. Mission Accomplished.

2 Likes

I think I found the issue and am invoking magic voodoo at the moment (as in copying images that are currently missing back to the right place, please stand by).

1 Like

2 Likes
2 Likes

Ok, all fixed. If you see any mysterious grey figures rather than your image then it’s just an out of date cache and will update shortly.

I don’t think anything is broken now, so any missing images etc then please let me know. Cheers! :beer:

1 Like

2 Likes

Mudspike with Frog keeping us on track:

Mudspike without Frog keeping us on track:

:beers:

4 Likes

le sigh

Update on this: A few grey avatars have appeared, so fixing that up now. We use a 3rd party thing called gravatar.com and it’s feeling unwell, or rather the forum software is not resizing the images correctly.

1 Like

Gravatar user here. Still going strong.

:flex <-- we need to make this a thing.

1 Like

Oops.

Still working on doing a fix for this. :expressionless:

If you have a grey icon then the easiest immediate workaround is just to upload your own avatar image here on Mudspike rather than rely on the Gravatar service default. Hit your icon on the top right and choose ‘Preferences’ (the wee cog icon) and then upload a pic at ‘Profile Picture’:

1 Like