Mysterious Blue Screens of Death (BSOD)

(Changed title) Original was: Mysterious X-Plane BSODs

EDIT: One Week Later… You can read my thinking and my actions below but here’s the punchline: It wasn’t hardware. And it certainly wasn’t X-Plane. It was Oculus. Since the problem isn’t universal among all X-Plane/Oculus RiftS users I am guessing that maybe a recent update of the Oculus software failed to fully clean after itself. So in conclusion, after a complete deletion of all Oculus software using Windows Safe Mode with internet off and a clean reinstall, all seems fine after two very hard days of use. Yay! One accusation below probably is true however. The recent Oculus update did remove some deprecated OpenGL functionality that Laminar Research have failed to take out of their library. Today (May 2020) X-Plane still lock or crash every time if run rendering with OpenGL.

I am not looking for help. This is just a public display of desparation. In fact, please don’t try to help. Because every unicorn that is tossed out as a possible solution will have me under the hood for another three hours thinking victory is at hand. Someday I will figure this out and I will paste my solution here as the one cause of my three days of X-Plane woe.

Three nights ago I downloaded beta 9 of X-Plane 11’s transition to the Vulkan rendering engine. That worked ok. No change really. I then installed FSEconomy which places a small python script and a plugin in X-Plane but otherwise manages everything off-sim. Then, after seeing that Mudspike Air Delivery was going to be a (mostly) Air Hauler 2 enterprise, I installed that. Like FSEconomy, Air Hauler uses a plugin but all functions are otherwise handled off-sim in an app. Seeing as MAD would be based in KEAT, smack in the middle of Washington state, I installed both the freeware airport and “Forkboy2”'s massive ortho scenery for Washington. Yesterday I had my first ever Blue Screen of Death (BSOD) on this PC. At first I blamed the beta and therefore myself. I normally avoid tweaks, mods, overclocks and most betas for the very reason that I laugh at stories like the one I am now telling. The long road to eternal frustration is paved with the crushed skulls of people who just can’t leave well enough alone. What’s one more skull? No one else using beta 9 was complaining so I figured maybe the new ortho wasn’t unpacked perfectly and was causing a stack overflow.

(what am I saying? I have no idea what an “stack overflow” is. Maybe I made that phrase up. Moving along…)

Later, I got another BSOD climbing out of Phoenix, far, far away from Forboy2’s Washington orthos. So then I thought maybe it’s all these crazy “economy” games and their pesky plugins. I removed those plugins. Another BSOD. I then emptied the shaderchache folder. Worked! I flew and flew. So I reinstalled the Air Hauler plugin and was an hour into my very first delivery and…

BSOD!

I restarted the PC and ran X-Plane without VR. I then let my DC-3 sit on the ramp at KEAT overnight. Next day, still there. No BSOD restart. OK good. I enabled VR and X-Plane locked up for awhile, turned black and then came back to life in 2-D and stuck for a moment, unresponsive, in the VR Settings screen. But it didn’t quite outright. When the moment was done it responded again but in 2D only. Restarted. Same. Screw it! I copied 200gb of sceneries and planes that I like and uninstalled X-Plane entirely.

I didn’t even use a saved installer. I went to X-Plane.com and got a new one. It took an hour to download. I ran the virgin, totally untouched version of X-Plane and it asked for an update. I let the update run for another 30 minutes and now I was up to X-Plane version 11.41, still totally untouched by me. I ran it. Exited out of the stupid demo. Set up a 172 on the ramp at Seattle. Great! Enabled VR.

Same damn thing!

It locked up for a minute and came back to life in 2D. I’ve tried a bunch of restarts. I’ve run the windows memory utility. I’ve run the disk utility twice. I’ve run both the current Nvidia driver and when that yielded the same stuck VR, I tried the latest beta drivers. Nothing works except the 2D version of X-plane. All of my sims including X-Plane exist on disk D:, an old fashioned harddrive. Disk C: is a ssd but is for system stuff only. I have tried every other sim in VR and they all work fine. Google Earth VR works fine. Condor2 flown hours on end in VR works fine.

But this plane jane, untouch, unmodified X-plane simply will not work.

Is it X-Plane? Maybe.
Is it the D: drive? Maybe.
Is it my 8gb NV GTX 1080? Maybe.
Is it my Oculus? Maybe.
Is it a memory stick? Maybe.
Is it Forkboy2’s Ortho? No.
Is it FSEconomy? No.
Is it Air Hauler? No.
Is it a plugin? No. None are installed that didn’t come packed with the sim.
Is it an airplane? No. None installed.
Is it a scenery? No. None installed.
Am I going start replacing hardware? Maybe. It’s easy to say, “screw X-Plane!” But that and Condor are the only essential apps I own. Otherwise I could toss the PC entirely and stick with my MacBook.

Someday, maybe today, I will figure this out. And when I do I will report back and promise never, ever to again mess with a system that isn’t broke.

One thing I should add, for what little it is worth, is that in recent memory, whether in VR or 2D, I have been unable to shut x-plane down. I have to hit “quit” and wait for the Windows “it’s unresponsive, should I kill it?” prompt. With the fresh X-Plane, even before I tried VR, it still refused to quit without being forced.

4 Likes

Not trying to help here :slight_smile:

If you’re not already doing this, give it a shot. This is only with the .50Beta and VR:

Plug in your VR headset before starting XPlane; whatever you’d normally do.

If a WMR headse then run Windows Mixed Reality, If it doesn’t come up automatically. Then run SteamVR…

Then start XP. If it didn’t exit in VR it should start up in 2D. If in 2D try activating the VR at this point. Continue as normal. Yeah, it’s a pain to config the flight in VR I guess.

I only say this cuzz a) I had similar issue, though with an earlier beta build, and b) someone mentioned this (somewhere in the ether).

“stack overflow” = Usually when a software function is stuck in an endless loop/call-loop. Not your problem to fix though, it’s the dev’s.

2 Likes

Not helping, but did you pull up event viewer in windows and see if it points you at the BSOD cause? Might help…or not

2 Likes

There is nothing in the event viewer of use. There is of course the warning that Windows shutdown unexpectedly and later restarted. Honestly, I think this is Oculus. A review of the forums indicates an unfortunate timing of the release of Vulkan and Oculus v.17 which came out last week. They say that if you run X-Plane rendered with Vulkan that it should work. But I am not ready to go the beta route yet. I am running a Oculus repair now and researching further to see if a simple-minded type like me can roll back to Oculus v16. Apparently v17 (the current version) does not play well with OpenGL which might explain why all other stuff works.

homie1

3 Likes

I don’t know why this sentence tickled me as much as it did.

2 Likes

Here is the interesting (POSSIBLE) solution: It might be that by using the beta I got one day of X-Plane that I otherwise would not have had. Follow me here.

Forget the BSODs for a moment. In Oculus there is (or rather, was) an OpenGL cubemap that has been deprecated for almost two years. Oculus warned devs about it but gave them time to ditch it. It is only called by X-Plane at the very instant VR is requested. And that’s where it hangs. That’s also where it hangs when you try to exit. Laminar never got rid of that callback. When Oculus v17 came out, X-Plane VR was killed for nearly all Oculus users EXCEPT those who checked the Vulkan box in the beta. So, if the internet trolls can be believed, this is Laminar’s fault. As for my BSOD’s…they probably indicate a different issue and I may well be screwed for awhile. I guess this a bit like researching your cancer diagnosis and discovering a kidney stone.

Sorry this is nothing like that.

Thank god airplanes don’t work this way…yet.

I had a failing Crucial SSD one time, which manifest itself in random x-plane crashes. I proved this by porting my XP folder to a USB drive, where it ran surprisingly well. Replaced the failing SSD drive, moved my XP install to the new drive, and all is well. Failing SSD drives are sometimes hard to detect because a lot of the time they behave well. My $0.02.

2 Likes

As for VR (not the BSODs I don’t think) there is a solution that works around the bug (or just use Vulkan). A user modified the OculusInjector tool to address just this one issue and posted it at github. I am using it but cannot say that it is safe:

https://github.com/rajetic/OculusInjector/releases/download/v0.0.1/OculusInjector.v0.0.1.XPlane.Fix.Edition.zip

Confusing screenshot. The top bit is OculusInjector and the bottom half is proof that VR is working.

[EDIT] Can confirm that Oculus VR works in Beta v9 (Vulkan only)

Here’s another observation about how rabbit holes are dug (when they are not dug by real rabbits.) In my first post I said that I had a blue screen while flying the AH2 mission out of KEAT. But when I tried to get back in with VR, it locked up. All true. But why, when I have already mostly determined that the BSOD had nothing to do with the Oculus bug? Because X-Plane detected a problem just before it shut down. (That evidence is all gone unfortunately) X-Plane is smart enough to know that a crash likely means Vulkan since that’s the big recent change. When I rebooted, it was in OpenGL but I didn’t notice. And that is why VR caused a lock out every time. In other words, spending today erasing and reinstalling X-Plane was probably for nothing.

I have been having similar problems, although not exactly the same. The most common issue I was getting was a failure to start the Nvidia graphics driver. I was having some issues with Condor too, especially if I scrolled through the different gliders in the hangar screen.
Last night I found some possible solutions on YouTube.
The one that seems to have helped is to go into device manager, go to the graphics adapter and ask it to update the driver. It will probably come back and say the one you have is the latest and greatest…but it seems to have helped. YMMV of course.

1 Like

sounds like condor’s the problem :wink:

If simming in general is starting to feel stale or boring, Condor 2 is probably the solution ;).

Speaking of which…(thread drift but I feel no danger of it drifting past this post)…speaking of which Daniel called today quite defensive of the Condor task last night. He said the conditions were identical to a task he and I flew with our club last week to teach weak conditions. I explained that, although I am sure that was true, last night was considerable harder. You only need to look at 7 finishes out of 38 pilots to know how hard it was. I am glad to have failed very early!

1 Like

LOL, I looked at the Air Hauler radar screen last night to see you flying the DC3…so I guessed you had landed out too (well, I actually went for it 100% and clipped a tree). Looking at the results, I don’t feel so bad about not finishing the course. I flew the task again this morning and I didn’t get much farther than on my first attempt.

1 Like

delete: Enough whining already!

delete: Enough whining already!

I should consider changing the title since I no longer think it is X-Plane. But it just so happens that X-Plane was always running when BSODs occurred.

I have:

  • Fully checked and defragged both drives
  • Run the Microsoft memory check three times
  • Removed the Page File (at 16gb I shouldn’t need it but since it was not the problem I will eventually put it back.
  • Checked all connections.

Here are the BSOD’s I can remember:

  • ATTEMP_EXECUTION_OF_NO_EXECUTE_MEMORY
  • PAGE_FAULT_IN_NON_PAGED_AREA
  • IRQL_LESS_OR_NOT_EQUAL
  • KMODE_EXCEPTION_NOT_HANDLED

What I haven’t yet done is checked GPU memory because I am not sure how. I’ll see if nvidia has something with which to stress-test it. This is where I normally say, “Go Apple!” but my 10yo iMac died in January. Served me well without complaint to the bitter end, though.

1 Like

I am still knee deep. I had another BSOD today. This is after moving X-Plane to drive C: (which is a SSD as opposed to the original home, drive D:, which is a HD. However, my C: is not quite big enough so I have a symlink to the Custom Scenery folder which I still keep at D: (the hdd).

The following are my notes from the Windows Events Viewer after this latest crash:

BSOD = IRQL_LESS_OR_NOT_EQUAL

Critical Events History
Last Hour = 1, Last 24 Hours = 5, Last 7 days = 15
last hour = “Kernal Power” 12:34:12

“The system has rebooted without cleanly shutting down first.”

Error Events
Last Hour = 7 Last 24 Hours = 88 Last 7 days = 575
last hour = “OVRServiceLauncher” 12:34:16

The description for Event ID 0 from source OVRServiceLauncher cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer. If the event originated on another computer, the display information had to be saved with the event. The following information was included with the event: [LauncherService] Unable to launch: There is no active interactive user session.

NOTE: Seems to happen on reboot

“Kernel-EventTracing” 12:34:18

Session “ERW USB tracing” failed to start with the following errror: 0x0000022.

NOTE: There are a BUNCH of these. They seem to happen on boot.
“volmgr” 12:34:11

Crash dump initialization failed.

NOTE: These happened on the last 5 “critical events” (BSODs) recorded.

“ESENT” (x2) 12:45:55 (so doesn’t really matter)
“Application Hang” 11:48:37 (so doesn’t really matter)
note: Referenced X-Plane.exe version 11.0.50.20 stopped interacting with Windows and was closed…
“EventLog” 12:34:15

The previous system shutdown at 11:57:27 was unexpected.

Warning Events
“BitFilter”

The driver has detected old or out of date firmware. Reduced performance may result.

NOTE: These are noted 2-3 seconds after each of the “critical events” below. Plus a few.

Past "Critical Events"
Critical 5/27/2020 12:34:12 PM Kernel-Power 41 (63)
Critical 5/26/2020 5:17:24 PM Kernel-Power 41 (63)
Critical 5/26/2020 3:23:45 PM Kernel-Power 41 (63)
Critical 5/26/2020 2:56:35 PM Kernel-Power 41 (63)
Critical 5/26/2020 2:34:46 PM Kernel-Power 41 (63)
Critical 5/26/2020 12:00:33 AM Kernel-Power 41 (63)
Critical 5/25/2020 10:19:43 PM Kernel-Power 41 (63)
Critical 5/25/2020 10:39:32 AM Kernel-Power 41 (63)
Critical 5/24/2020 10:49:38 PM Kernel-Power 41 (63)
Critical 5/24/2020 10:42:16 AM Kernel-Power 41 (63)
Critical 5/23/2020 8:34:38 PM Kernel-Power 41 (63)
Critical 5/23/2020 6:33:13 PM Kernel-Power 41 (63)
Critical 5/23/2020 1:13:25 PM Kernel-Power 41 (63)
Critical 5/23/2020 11:49:41 AM Kernel-Power 41 (63)
Critical 5/23/2020 11:39:11 AM Kernel-Power 41 (63)
Critical 3/27/2020 5:55:21 PM Kernel-Power 41 (63) (from March)
Critical 2/13/2020 9:13:53 AM Kernel-Power 41 (63) (from Feb.)
Critical 1/14/2020 10:02:44 AM Kernel-Power 41 (63) (from Jan.)

Basically after all that investigation all I know is that there is no way to know. BSOD’s are the perfect murder. They leave no evidence behind. The system can only record what it knows and it can only know that for some reason it had to reboot. Once that happens numerous normal errors show up that seem like smoking guns but they are all after the fact.

EDIT one week later: None of this is true… Here is what I THINK might have happened. The very first BSOD occurred soon after installing FORKBOY2’s Washington state ortho scenery. To keep the size down, the dds files are packaged as JPEGs and zipped. To convert all 8900 JPEGs, Forkboy points the user to another guy on the dot org site who’s made some batch files to automate the conversions. The fastest batches assign conversion tasks to each gpu core (this is only available for nvidia users). I tried this twice and both times it caused a crash. Not a BSOD I don’t think but a crash and restart. My weak theory is that this process beat up the GPU in some physical way. (BTW, I was able to make the conversion using the much slower CPU batch file.) Why does this only happen with X-Plane? No idea. I’m just winging it anyway. But so long as I am walking out on this limb, I’ll suppose with no knowledge to back up the supposition, that X-Plane uses GPU memory in ways that other sims do not? Or maybe it’s just placebo because I haven’t been using other sims other than for testing since the crashes started.

To test this I ran FurMark’s GPU stress test for 30 minutes with no issues. I won’t paste it here. It’s 80 lines of numbers with “[NORMAL]” and a bunch of values.

I said in post #1 that I don’t want help. I just didn’t want to be steered in a thousand different directions. But I have done all I can. I can’t afford to buy a new GPU to test maybe only to find that it’s a hotrod bolted to a failing mobo. The memory sticks are less than a year old. You can see above that I’ve tested them multiple times. It may be the hdd or sdd. The cheapest and easiest thing to do is replace the hdd with a big sdd I guess. Anyway, that’s all I’ve got. Help is graciously appreciated.

This is all only happening with X-Plane though right? (Sorry…that info might have already been posted up there earlier)

Have you monitored the temperatures of CPU and GPU, while running X-plane?

I had to adjust my fan profiles, to keep CPU temps acceptable while running XP, even though temps were fine with other games including DCS in VR.
While it didn’t BSOD on me before adjusting the fan curves, it did totally lock up multiple times, and had to be restarted using the power button.
After getting temps down, no more lockups, only the occasional Vulkan device lost error (beta9)

© 2020 Mudspike.com | Articles Website | Forums Rules & FAQ