New PC, trouble with Warthog scripts

So I built a new PC and was pretty much forced into Windows 10 with the i7-7700.

The computer is up and running, but I’m not happy with the handling of drivers. Struggled with the ethernet driver for a couple of hours and finally managed to do a manual driver install then disabled windows driver auto-updates.

As I was installing P3D and add-ons, I installed the Warthog and trackIR with little difficulty and went for a short flight around the pacific northwest. KSEA → NAS Whidbey → 1S2 → KSEA. (Was surprised to see a fireworks show in Seattle as I headed back to KSEA. Anyway, the point is that I was able to load my warthog script which I wrote in 2011 (with minor tweaks now and then) and fly with it and trackIR with no issues. That was Saturday.
Oh, one other thing I noticed in the thrustmaster “device analyzer” was that the Product ID text was not displayed in the device selection menu.
All I saw was:

Selecting the “HID” before the Razor turned out to be the Joystick and the one below was the Throttle. This seemed odd to me, because I was accustomed to seeing “Thrustmaster Warthog joystick” and “Thrustmaster Warthog Throttle” , but the axes and buttons seemed to work fine and when I ran the script, I saw the Vid/Pid listed in the status window as the script was started up and the “Thrustmaster Combined” virtual device was created.

Sunday, I decided I didn’t like the way the cables were routed so I connected the stick and throttle and razor through a HUB – which is exactly the way they were connected on my windows 7 machine.

Pulling up the device analyzer again I saw a longer list of HIDs with the Razor still in there. I eventually found that two of them were the stick and throttle and checked them in the device analyzer. They were working fine.
When I ran the script, the status window found both the stick and the throttle, but this time the script stalled on “installing filter for [throttle Id]”. I don’t remember the exact string, but the part in brackets was the throttle.
The lights went out on the throttle and the script timed out and failed to run.
I had to move the throttle to another USB port to get it recognized by windows again.
Re-ran the script and it failed the same way.
Changed USB ports AGAIN and the throttle is back again. I have not run the script again yet.

And that’s not all! :slight_smile:

Now, I decided to test things out in the sim and TrackIR wasn’t working.
In the trackIR window it said: “No device detected”

I had to do a manual removal and installation of the driver to get it working again. And it did work in the sim.

Has anybody experienced anything like this? Looking for advice please.

32 GB DDR4
250 GB SSD
EVGA 1080 Hybrid FTW
Windows 10 Pro

Oh, and I have a pair of Simped rudder pedals connected through a RealSimulator RusbA and it works fine.

status window from script editor:
Physical USB HID devices managed by script!
Currently plugged USB HID devices[2]:
1: “Throttle - HOTAS Warthog” - “USB\VID_044F&PID_0404&REV_0100”
2: “Joystick - HOTAS Warthog” - “USB\VID_044F&PID_0402&REV_0100”
Installing filter driver to VID_044F&PID_0404. Please Wait…Script stopped!
Error:(internal) cannot associate a filter with the selected USB HID device “VID_044F&PID_0404”

Runtime Error: STOP request received while running main on line 38 in “F:\Warthog Configurations\P3D_a.tmc”
Error:Script run timed out!

I’m not sure if I’ve seen this line in the status before – then again, I’ve never really paid much attention to to output there, because it hasn’t failed there before.
If you’re wondering, line 38 is near the top of the script and is part of every script where TARGET is instantiating the device. At this point, it hasn’t even gotten to my custom code.
Finally, if I re-run the script, the throttle is not shown as a currently plugged in device.

For those interested, I resolved this problem by downloading the old version of TARGET and installing that package and driver set.
Of course, I cleaned out the “new” USB drivers before installing the old version.
Script is running again. Whew!

1 Like

Welcome to Thrustmaster Driver Hell. I feel your pain. Even with tried and true Windows 7 I still have problems from time to time. I fear this the most about doing a reinstall.
Sorry you had this problem but I am glad to see you worked it out. To me there is no other stick worth having more than the Warthog.

I had the exact same problem.
Just created an account just to Thank You for your workaround, it work for me using old Target software and old driver.
I had the good idea to backup my drivers setup and found the old one : “2014_TMHW_1.exe” for the stick and throttle. And reinstalled the old “TARGET_v1.0.exe” too.