New SSD, Windows 10 Reinstall - Cheats!

The Issue

I recently went and bought two WD Black SN750 500GB Nvme drives for the purpose of replacing my C drive and the one hosting my DCS installation. Since 2.5.5 came out, I have been having numerous “micro-pauses” in DCS that last upward of 5-10 seconds (enough to turn a cat launch into a swim).

Analyzing my system with the performance monitor up showed that my 32GB of RAM had plenty free, my i9-9900k could take a lot more work before being overburdened, and the SSD for DCS was doing rightfully doing nothing, as everything was loaded into RAM. However, every time Windows was working and accessing C, the game paused. C drive average response time hit over 4 seconds. To note, my C drive is an older Kingston SSD Now - these are cheap and from my experience - durable SSDs but the performance is what you pay for - less than $100 for 256GB if I recall correctly, and that was back in 2014 or so. Time for some real SSDs, and I picked my new motheboard specifically to handle two NVme’s without axing a SATA port.

But you can just migrate!

Yes you can - but from what I read, there are many times this doesn’t work. I also read (but cannot technically verify) that the bootloader gets different drivers for Nvme/PCIE storage than SATA. So my best course of action was a fresh install. I didn’t want to be out of action for a week while I re-install everything though.

The Setup

My rig (now) has the following drives, letters were the same before except as noted:
C - Windows 10 (Nvme - WD SN750)
D - Windows 10 (Old SATA Kingston "SSD formerly known as C)
F - Sim Drive (500GB SSD [S drive on old Windows)
M - Media Drive (2TB HDD)
R - Recording Drive (2TB HDD)
S - Sim Drive (Nvme #2 - WD SN750 - Clone of F)
W - Warcraft (256GB SSD, formerly WoW, now just other games)

Installation - Hardware

A clean install is always best done with no other drives present. This also ensures the boot partitions are on the same disk as the new C drive. I didn’t want to pull cables so this is what I did:

  1. Shut down the PC

  2. Install one of the new NVME’s.

  3. Boot into BIOS, then disable the SATA controller.

  4. Boot to USB Flash drive with Windows 10 install media (you can make a install USB using a tool from Microsoft’s website:

https://www.microsoft.com/en-ca/software-download/windows10

  1. Once in the new Windows installation, I needed to prevent the annoyance of having the bootloader display this:
    Pick an Operating System to boot:
    Windows 10 Pro
    Windows 10 Pro

So I found a command to rename the new OS on the bootloader:
https://answers.microsoft.com/en-us/windows/forum/windows_7-performance/how-can-i-edit-the-os-name-in-the-boot-manager-of/19891f91-0076-e011-8dfc-68b599b31bf5

This new install is now “Windows 10 [NVME]”.

  1. I shut down and installed the second NVME drive, then booted back to BIOS and turned my SATA controller back on.

  2. Booting back up, it turns out step #5 was a waste, as my board automatically goes to NVME first. If you were going to another SATA disk, it would be worth it.

Installation - Windows

  1. Back in Windows, I used the Partition Manager to setup the second NVME, and correct all the drive lettering for the other disks.

  2. At this point, Windows 10 would not activate - like when I migrated to my current CPU/Mobo.
    a. You can call Microsoft for them to re-assign your license to your computer if the automatic tool fails: 1-425-635-2970. It was late at night, and I didn’t want to be on the phone so I opted for another solution.
    b. I found out that someone wrote a Visual Basic script to pull the encrypted key out of the registry. You can read on it here: https://www.winhelponline.com/blog/view-your-product-key-windows-10-8-7-script/

  3. I returned to BIOS, and manually booted into my old Windows to run the VBS script. It worked, so I saved the key in a text file on my M drive. Rebooting to the NVME, I entered the key and Windows re-activated with my digital entitlement on my Microsoft account. Easy!

Installation - Games

  1. First I copied the now F drive to the new S drive (which was/is DCS, the Steam edition - this would work for the ED installer too, I gather).
  2. Next installed Steam, and told it to install Borderlands 2 on W drive, which it picked up all the existing files for Borderlands 2, Borderlands, and the PreSequel without me doing them individually - awesome! When DCS finished copying, I followed the same method telling it to use the new S drive.
  3. Before running anything, I took a break and installed all my drivers - graphics, wifi, etc. Some apps like Discord I did while doing other things prior. Multitask!

All my HOTAS keybindings!

  1. It’s time to kick up the cheats. I opened up D:\Users\Wes\SavedGames and copied DCS. Then I quickly changed the D to a C in the address bar, and hit paste. Settings - done (almost)!

  2. I also went to D:\Users\Wes\AppData\Roaming and copied all folders for NaturalPoint (TrackIR) over to the equivalent location on C. TrackIR profile - recovered!

  3. Let’s start DCS. Settings menu - everything as it should be. Perfect.

  4. HOTAS bindings - missing. No problem.
    a. Select a plane on the control setup screen.
    b. Single click an empty cell under one of your HOTAS devices.
    c. Click “Load Profile” button.
    d. Navigate to: C:\Users\<You>\SavesGames\DCS\Config\Input\<Aircraft>
    e. Select the file for that device and click OK.
    f. Do a quick verification, especially for AXIS. Some of the times, I had to go to the AXIS page and load a device again for those to come in.
    g. Repeat substeps C-F for each device for that aircraft, then return to step A and select another plane.

  5. Do a test flight! In my case, all good!

Don't Re-Configure Microsoft Outlook

I am a Office365 user. I have both my email address set up as IMAP (which uses a .OST file in your AppData folder) so they sync with my phone. To avoid a full mailbox, I also have Outlook use Autoarchive to move old mail from both accounts to a single .PST file in my OneDrive (which is re-mapped to my M drive). I don’t want to re-set all this up, so I need the old files and my old profile.

  1. Returning to the appdata folder on D, I copied everything for Outlook over to C. You need to look here:
    a. C:\Users\<You>\AppData\Local\Microsoft\Outlook
    b. C:\Users\<You>\AppData\Roaming\Microsoft\Outlook

  2. While the OST and some config information is in AppData, and my PST is safely on M - the profile is actually in the registry. So I booted back into my old Windows and ran RegEdit to get the keys.
    a. Most of the keys are here: Computer\HKEY_CURRENT_USER\Software\Microsoft\Office with some under the 16\Outlook and some just under Outlook. So I exported the entire Office key, and saved it to the M drive.
    b. In the new Windows, I loaded the keys into the registry.
    c. Upon starting outlook, all I had to do was re-enter my email account passwords, and everything was back exactly as I left it. Autocarchive settings and all.

Fixing OneDrive

  1. When OneDrive first prompts to setup, you can select another location for it’s folder. I told it to use M drive again, as all the files are still there from before. If you want to change it’s path after, you have to sign out and back in again from OneDrive. Two days later, it was still stuck on 100 files that would not re-verify. Queue the investigation. Closing and restarting OneDrive is one of the listed solutions to a hung sync, but it didn’t work for me. So I tried to open a PDF file in my OneDrive and got a “file inaccessible” error from Adobe reader. Okay, that’s easy to fix.
    a. Right click OneDrive’s folder and go to Properties -> Security -> Advanced.
    b. See that random string of characters? That’s my user ID from the old Windows, if the user account existed on this Windows, it’d be my name.

    c. Next to Owner, click CHANGE. This brings up the dialog to find a user. Type in your account name or email address (if using a Microsoft Account) and click Check Names to verify it’s good. Then Click OK.
    permissions2
    d. Now we don’t want to do this for every file and folder - so we want to do this recursively, and automatically get everything. Two checkboxes take care of this:

    e. You may get a warning about replacing some of the permissions, it’s OK to proceed.
    f. My OneDrive immediately finished synchronizing.

Project Complete

With the worst of it all taken care of, now I only have basic software programs to configure and things like my printer drivers to reinstall. That doesn’t need to be written about though. I am already enjoying DCS stutter free and will fully wipe the D drive once I am sure I don’t need to pull any other files or registry keys. I acheived most of this in about 4 hours one night, with some of the OneDrive stuff carrying over the following day. With how fast modern computers and storage is, plus having a few tricks and tools - reinstalling Windows on your main system does not have to be a dreadful task that crushes your soul. If upgrading and having to reinstall is making you hesitant to make use of new and better hardware, hopefully this will help you overcome the software issues and move up in the fast lane!


Edit (June 29th, 2019):

iTunes, You *****

(Please replace the above asterisks with your favorite insult from TopGear/The Grand Tour with the appropriate accent for best simulation of my mood on this matter :sweat_smile:)

I have always like iTunes for it’s very simple media management, and the easy of ensuring songs are tagged and even include lyrics on my iPhone (I grey up with a 3rd gen iPod Nano, then a Touch, then iPhone 4s, 5s and now 256GB Xr). I have always migrated my libraries when I rebuild, and iTunes is the reason I have the “M” drive (which stands for Media, of all things!).

Needless to say, going into iTunes preferences and redirecting it to my old library would restore the media, but not the library itself with my playlists, play counts and the like. In fact, each time iTunes was re-opened the damn library was pointed back to the C drive. The Apple forums had the solution:
https://discussions.apple.com/thread/250295465

In fact, all you need to do is close iTunes. Then hold the shift key down while double clicking iTunes’ shortcut to restart - and keep holding it until the library selection dialog comes up (this can take longer than you think it will, but it’s measurable in seconds - not minutes). Now, located and select your previous .itl itunes library file. Done!

I would always recommend media be on a secondary disk. Redownloading nearly a terabyte of media would take ages for anyone not on a fibre connection - and many still have bandwidth limits.


Edit (July 9th, 2019):

Intel RAID - Easy!

Years ago I had my main data & media hard drive crap out. Painfully, I was able to recover the data, partially, losing hundreds of photos and videos I had taken. Redundancy and backups are now something I like to have covered. The “M” drive backs up to the HolloPointe North server, which started life as a family file-server. There is also the OneDrive link, but my iTunes library exceeds the 1TB OneDrive limit so it’s site separately hence the additional coverage.

  1. Install the appropriate Intel Rapid Storage Technology (IRST or “RST” as Intel refers to it). First, go to your motherboard’s support page and use the latest appropriate driver there. If you run the application post install (and reboot!) and it demands an update, then head over to Intel’s website. The key with Intel’s site, especially if you have older hardware - is to make sure your chipset is still supported by the latest driver package.

  2. Begin RAID Setup on the CREATE menu of IRST. Yep, we’re bypassing BIOS setups. I am using RAID1 to create a mirrored set, which offers protection incase of disk failure.

  3. Select the drives and what to keep. Select the disks you want to array together. You can mouse over the data on the right to get the disk’s model, serial number and port number. This is important for selecting what drive to keep as IRST doesn’t give you the current drive letters. You can further confirm by matching with the drive’s properties window in Windows Explorer. I did my RAID array already, so ignore the mismatched drives shown here. It’s best to use equal sized disks.

  4. Confirm and go! The array will immediately begin rebuilding by wiping the non-chosen disk, and copying the “keep” disk to it. During this time the “keep” disk is fully available, but don’t write to it as this would likely extend to rebuild time. A build for 1.2TB of data took about 12 hours for me.

The Blue Screen of Death

Nothing can just work. You will BSOD at some point. Here’s some tools:

  1. BlueScreenViewer - I forget where I got this but a quick Google search will have it up in no time. Quite handy as you can read the data at a moments notice and see all the memory dumps (from C:\Windows\minidump) in one go. The catch is it doesn’t always seem to read deep enough. In this instance you can see it’s blaming the Windows’ kernel and an NVidia driver. I know there is nothing up with these, so deeper we shall investigate.

  2. Previously, you could visit the MS tech forums, upload your minidump file and wait for someone who knows what they are doing to give you an answer. Windows10 lets you skip ahead. In the App Store is a free tool - WinDbg Preview.
    a. Install the tool and make sure to Run as administrator, this is actually a privilege level above the administrator user account type, and is needed to read the minidump files. Running otherwise leads to “File not accessible.”


    b. From the menu, browse and open the appropriate minidump file. Then once it loads, select the analyze link on screen.

    c. Scrolling through the results we find our true target. Here we can see the code is number 133, a “DPC_WATCHDOG_VIOLATION” caused by iaStorAC.sys - the Intel Rapid Storage driver.

    d. Here is where the troubleshooting really begins. I had bypassed this before by not using the IRST software, but I want my RAID1 array. So I will have to play around with various driver versions to find one that works.

9 Likes

Thanks for taking the time to write this all out, the OneDrive and Outlook sections are definitely going to come in handy!

1 Like

Wow. Great writing!
Thanks!

Thanks for another great Mudspike Tech Support guide @Wes !

Hey guys, thanks for the kind replies!
I have added another bit of information on restoring an iTunes library for anyone that may need it.

3 Likes

I have to bookmark this post. It’s going to be useful soon :slight_smile:

1 Like

Updated again with a quick note on Intel’s Rapid Storage Technology, RAID1 Configuration and some BlueScreenOfDeath debugging.

2 Likes