Oculus Rift S has a well-hidden resolution setting

For those who might not already know: (I think I may have known once and then forgotten)

Oculus Rift S has a well-hidden resolution setting

The Oculus Rift S has a fairly hidden setting which changes the headset’s default resolution. The setting does not state the resolution for each choice, but we were able to discover it with some digging.

How to find and change it

To find the resolution setting for Rift S, open the Oculus app, click “Devices” and then click on “Rift S and Touch”:

In the list of settings that appears, scroll down and find “Graphics Preference”:

You’ll now see the Graphics Preference panel. This lets you choose between “Quality” and “Performance”:

The setting can be changed on the fly, there’s no need to restart the Oculus software or even to take your headset off.

‘Recommended’ different based on GPU

We tested on a GTX 970 and found that this setting was set to ‘Performance’ by default, which was Recommended. We also tested on an RTX 2070 where it was the opposite- set to ‘Quality’ by default.

We asked Facebook whether this is done to maintain the same recommended spec as the original Rift and a spokesperson confirmed it is. This setting did not exist on the original Rift, which had lower resolution than Rift S.

What it actually does

This setting changes the default 1.0x per-eye buffer resolution for the Rift S. By querying the SDK we found the exact values it uses:

Prioritize Quality: 1648-by-1776

Prioritize Performance: 1504-by-1616

This is of course only the default resolution. Some games let you scale the resolution factor in the menu. Many others use the Adaptive Resolution feature of the Oculus SDK, where the resolution scale is automatically changed on the fly based on your current GPU utilization. Alternatively, you can use the Oculus Debug Tool to override the resolution scale yourself.

If you have a lower end gaming PC you’ll want to use the Performance setting to maintain framerate. On a high end rig you should make sure it is set to Quality.

Have Fun!


Thanks for the reminder ! I replaced my 1070 with a 6800xt , and forgot to select “quality” after the change . So your thread is both timely and helpful . Thanks again !

1 Like

My Games are still playable on my MSi Lightning 7970, lol.

1 Like

I had to google what that even was…

3Gb of ram?!

1 Like