Oculus Rift - SPUD / OLED mura in X-Plane

I’m getting ready to run out the door, or I’d have more direct observations and input on this (I’ll test it when I get home), but I found this interesting.

I’m really enjoying X-Plane in VR, particularly night flying since it really puts me in that full motion simulator feel from so many years of sitting in the box. X-Plane VR has improved over the past year or so and framerates have continued to improve. The latest version is very good, but I did think that the night sky stars are a bit TOO bright and twinkly.

Well, I ran across this post today on the X-Plane VR forum:

“I noticed that anytime I flew at night there was always a faint linen-like effect on my windscreen. Anyway I tried the suggestion from reddit about disabling SPUD and this has worked very well for me. Night time flying is clear as a bell and I think even daytime looks clearer.”

I downloaded the BAT file that appears later in the thread to allow you to select SPUD ON/OFF, disabled mine, and loaded up an X-Plane night flight. Indeed, the stars don’t twinkle (or bloom I guess) nearly as much, and I really liked what I saw. I need to do some comparisons though to determine if this is something that is worthwhile or not.

@fearlessfrog might be able to fill us in on SPUD and what it is or isn’t and whether turning it off is a good idea or not…(?)


I always wondered what that spud did in there…


The spud file is an overlay the oculus driver uses to compensate for crappy screen quality in the first couple of batches they made. Unless your oculus looks horribad without it (and there’s a pretty darn phat chance it won’t), there’s no need for that ugly kludge to remain active on your machine.

I’ve said it before, and I’ll say it again: Oculus hardware is heavenly but their software design team should be hung by their testicles and fed undercooked spaghetti until they went to their rightful place in hades. F that S.

1 Like

Man, I cannot wait to give this a try! Night flight in DCS and Il-2: BOS is practically unplayable for me because of this effect.

Hmm, no joy. Either the SPUD-OFF setting didn’t register or it wasn’t the problem.

I get this issue in both DCS and Il-2. Night flight just doesn’t look clear and crisp. Instead, it’s like I’m looking through a piece of light cloth or a haze.

I’ll keep experimenting.

1 Like

Well, some success. I went into ‘C:\Users\XXX\AppData\Local\Oculus\Spud’ and deleted everything in this folder. Restart, fired up DCS and night time looks crisp and clear. No more hazy, thin cloth effect over everything.

Unfortunately, no effect in Il-2. I need to fiddle with my gamma settings. I might just have them too high.

1 Like