Odyssey+ hmd preventing pc from shutting down

I have been having this issue of my pc taking more than 5 minutes to shut down. After extensive troubleshooting, I have determined that my hmd is causing the problem.
Now that I know the cause, I am sort of at a loss as to how to proceed to fix it.
Does anyone have advise on how to proceed?
thanks

1 Like

Could be a bunch of things, and they are usually power plan related.

To narrow it down to just the headset, try running ‘Device Manager’ (press the windows key and type that), open up ‘Monitors’ and right click on ‘Mixed Reality headset’. From there hit ‘Disable device’ and then see if you shut down ok. If you do, then it is probably the headset or the graphics card.

Thanks for the quick reply…
I have already figured out that it is the headset. If I unplug the headset and boot the computer,
it shuts down in less than 10 seconds. If I plug the headset in and boot, it takes 5 minutes to to shut down.
I have tried making sure that no apps are running. I closed the wmr app, closed all apps in the system tray, launched task manager to make sure no apps are running. After doing all this, no change. As long as the headset is plugged in, the computer takes forever to shutdown. The only thing that happens during shutdown is that the graphics card no longer send a signal to the monitor,as normally expected, but the case fans, graphics card leds, motherboard leds all continue to operate for about 5 minutes. Then all shut down.

It would still be handy to try, as it would tell you if it was a software issue causing something to hang on to the GPU (as it’s disabled) rather than just unplugging it, which could indicate a hardware issue with the headset. Knowing that it shuts down ok plugged in but disabled points more at a software rather than hardware issue.

These things are hard to diagnose and fix, as could be lots of things. One thing that wouldn’t hurt that is worth a try (if the disable and shutdown indicates it’s not a hardware issue), would be to reset your power plans. Maybe option two here? https://www.tenforums.com/tutorials/43774-reset-restore-power-plans-default-settings-windows-10-a.html

Hi,
I replugged in the hmd. Booted computer.
Then disabled the headset in device manager. Computer shut down normally.
I then rebooted and went into power options. I reset balanced to default and chose that power plan. When I tried to shut down, same issue arose.

I’ve actually been seeing this same issue with my new PC, but am not sure if it was the PC or the most recent Windows or SteamVR update that is causing it. And I did not know that the PC would eventually shut down after 5 minutes…I gave up after a minute or so and just manually hit the power button to shut down. I’ll be curious if mine would indeed shut off after X minutes.

I’ve also had some trouble lately with donning the O+ not turning on the screen inside. Mixed Reality Portal is already running, and I can even see head tracking in something like X-Plane, but the screen in the headset never turns on (but there is sound). A reboot fixes it. Again, not sure if it was a Windows update, Windows Mixed Reality Update, or a SteamVR update that has caused these issues.

Not seen that as yet. Maybe try updating to the May 2019 1903 build, as that will rewrite a bunch of stuff and is inevitable anyway? You can use the ‘Update Now’ from here:

https://www.microsoft.com/en-us/software-download/windows10

I’m wondering if there isn’t something going on with Revive too. Is there a quick way to toggle that on and off (as in prevent it from loading when I load Mixed Reality Portal?). I was just changing settings in X-Plane and (this has happened a couple times today) got dumped to the desktop and the Oculus software is running on top of everything. :thinking:

I think it’s just as easy just to uninstall Revive and see if it’s that. The Start menu / Revive has an uninstall option I believe.

1 Like

I’ll troubleshoot tonight - I also added Active Sky XP which could be throwing up some issues. And I also updated X-Plane this morning - so I really created a matrix of possible problems. Haha… But to @dpj463’s point, I’ll see if I can pin down what is causing the computer itself to stay on on shutdown.

Btw, one of the nice features of the 1903 update to WMR is that you can run any Windows app in the Cliff House / Loft world thing. It’s sort of cathartic to be able to ignore a Word document in 3D just like it is in 2D. :slight_smile:

Heads up: 1903 is a big update, so set aside some time to do it. If you do do it, it will fail or not offer the update unless you remove ‘Program Files (x86) / Common Files / BattlEye’ folder (if you have it installed, it’s an old EA anti-cheat driver that some game used to use, the roll out is waiting for EA to replace it).

Honestly…you know what I really need in VR - the ability to see the infuriatingly more frequent text messages that keep chiming on my cell phone. As you know, when you have a kid, you have to look at every message and answer every call in case they decided to rob a bank or climb an antenna or something. I can’t tell you how many times I’ve had to lift my VR headset to peek at my phone. I hate it (the phone that is).

Cool…looks like I don’t have that one.

Cool. Update complete. Now I have to go to soccer. LOL…

1 Like

Stuff in it to read at the game. https://www.theverge.com/2019/5/22/18635282/microsoft-windows-10-may-2019-update-features-review

1 Like

Hey @BeachAV8R, possible 1903 and O+ fuzziness issue. Checking for the updated driver and using 212% rather than 200% SS helps in SteamVR apparently. Not at a PC but thought I’d pass along if you are seeing this (I think I did in DCS last night):

1 Like

Yes - going from 200 to 212% sharpened things up. Really odd.

1 Like

I think 1903 sort of broke Steam WMR a bit. Best guess is that it is now ignoring the settings in default.vrsettings. Remember that bit that now defaults to ‘2.0’, it seems to just run at 1.0 now regardless. Microsoft is a clown college for this stuff. Annoying.

To fix it, it seems easiest just to roll back 1903. In Windows Update you hit ‘Recovery’ on the left and it should fix things up.

1 Like