OpenVR AdvancedSettings Utility

I noticed this earlier and found this

1 Like

Yeah, I remember. It makes sense for the tall vs wide nature of the view. I was most surprised by this though:

So same resolution panels, but oversampling both in height and width for the Pro.

1 Like

I remember my math teacher saying “something something…this will come in useful something something…”

I guess I should have paid more attention.

I thought a quadratic was a four pack of beer instead of a six pack. Hmm…interesting…

My menu doesn’t look like that one. Where did you access that?

The wiki page on the instructions, I didn’t screen grab.

EDIT: I haven’t even set up Mr New, so couldn’t check - I should get around to that… Hmm.

1 Like

Better open that. Might be a Rift in there. :vr:

1 Like

Experimenting with this. I finally did find that tray menu in Steam VR…it wasn’t as obvious to me how to find it, but finally stumbled upon it. Oddly enough, mine was set to a default (I had not changed anything of 1.8 SS. I actually bumped it down to 1.6 thinking that is more appropriate for the O+? I might try sliding it all the way to the right just for giggles and see what happens.

I’m always wondering if I’m suffering placebo effects as I adjust things. For a bit, I was questioning whether ANY of the setting were doing anything, but then I set VTOL VR to application 20% and application 500% and you can see a big difference particularly at the low end. Over 200% and I don’t see a whole lot of difference, almost like there is diminishing returns going higher. That said though, VTOL VR is smooth even at 500%.

I’m still a bit fuzzy (pun intended) on the 1.6 and 500% - is that 1.6 x 500%?

EDIT: Ah, see what you mean, yep, it would be 160% x 500%, as if you have two settings they combine.

Also, some apps/games don’t change on the fly, so restarting comes into play.

1 Like

Yeah…I’m pretty much exiting everything before applying new settings. I didn’t have to exit Steam VR though for instance for VTOL VR. Just exit the game, make the adjustments in Steam VR, then relaunch and they took effect.

Now playing with DCS. Really trying to find the sweet spot for that. Again, just for self-demonstration factors, I upped the PD in DCS to 2.2 and it becomes a slide show. 1.6 seems fine. Amazing how such a small change in that sim in particularly can make such a big difference. And really, going from 1.6 to 2.2 makes almost no difference in cockpit legibility. I might back down to 1.4 and see if I can tell any difference there.

1 Like

So DCS uses the quadratic scale for its pixel density I think, so that 1.4 to 2.0 is like going from 144% to 400% in a SteamVR app. Basically the difference between the scales is either taking the width or taking the combined resolution - it’s just different ways of expressing the change in size, but SteamVR had to find something that dealt with different width x heights in a single number, rather than the Rift single device that doesn’t have that problem.

1 Like

For some reason on my system the application supersampling is always set to 0.3. I try changing it but the value does not stick either.

Anyone else ran into this?
(i also only have the first checkbox checked off, using either rift or pimax 5k plus)


Could it be values set in the SteamVR / Settings, as in the Video and Application settings are overriding those?


I checked this though, under video mine is not checked off (though if i temporarily check it, it shows 28%).

Application set to 100% at least for the title i’m running. Uninstalled steamvr and no change unless a setting is sticking somewhere.

If ‘Enable customer resolution’ is checked off then it will use the recommended setting for your GPU, which it seems to saying is 28% (i.e. undersamping). That would explain why it says ‘0.3’ in your OpenVR application supersampling value.

What’s your graphics card and system? I think the SteamVR adjusts that automatic value based on a bunch of values it sees from your PC performance.

Yeah in my case enable custom resolution in 2D is not checked, so not sure.

So just to be clearer, I think you need to tick that ‘Enable custom resolution’, move that slider manually to 100% and then go back to OpenVR AdvancedSettings and then your slider will not be greyed out. Sorry if you already got that and I’m repeating. :slight_smile:

No worries… ill try enabling the check box for custom res, set to 100%, then go to the advancedsettings in VR… and see if application supersampling then says 1.0 (its not greyed out in my case, just says 0.3 and is adjustable but doesnt stick)

I’m on i7 8700k 5.0ghz and 1080ti in my case (rift or pimax 5k plus)

1 Like

Well i thought the fix was found… i did the video override at 100% left application at 100%… in advanced steam in vr it now shows 1.0
However… i’m getting 1 fps in xp11

I unchecked video… override… and set the application to 220%… things are much better, but not quite as rift quality in terms of sharpness (it states it renders each eye at 5454x2583)

Here’s what I used for DCS, not sure that helps, but XPlane 11 is very frame hungry in VR:

Thanks, yeah thats basically what i tried… but for some reason the two combined cripple xp11 and it reports a crazy per eye resolution (i guess they really combined). I’m going to retry all this on a bare windows/steam install and see if it behaves differently. I think another vr title i tried (wasnt dcs though i could), was ok though. Vulkan cant come soon enough for xp11