VR News: HP Reverb - Second Gen headsets are on the way

I also just fired up my O+ again, with the realization that I might have to look seriously at the Reverb. I’m still not getting along with WMR/SteamVR though. It’s working, but just not working great. Until I can find out what I’m doing wrong to get to the point where I feel I am getting a better experience from the O+, I see little point in committing to the Reverb. It’s not the hardware, it’s the software that seems to be the problem.

Hmm…that’s odd, or at least, it hasn’t been my experience. My order of operations is pretty straightforward.

My O+ is normally just sitting on my desk in sleep mode. I pick it up and put it on, which auto-activates Windows WMR and takes me to the WMR Cliff House. Once in the Cliff House, I have a little “TV screen” that I point at that launches SteamVR, which takes a few seconds to load. Once in SteamVR’s house, I choose what game I want to play from the wall.

I just timed it - it took 17 seconds for WMR to launch and get me ready in the Cliff House. From there it took 15 seconds after selecting the SteamVR “portal” window to reach SteamVR.

My only real complaint about the O+ was that it didn’t come out of the box with the comfort features I added (the headstrap and the replacement face cover) which added probably $75 to the ultimate cost of the headset. And I prefer the Rift Knuckles to the O+/WMR ones for sure, although I’ve learned to like the new ones.

I like not having to have the external sensors for tracking, but I do think the external sensors track better when wands are out of view or behind your ear…usually not a problem in the kind of games I play (sims), but occasionally that manifests itself with a glitch in tracking if I have my head craned one way and my controller is out of the periphery.

I live with the shortcomings because the picture is just so much better (in my opinion) and everything else just falls to the wayside.

1 Like

We can probably help if you want help, but you’d need to say what the issues are I think.

Is it a frame-rate issue? A tracking issue etc? Are you on Windows version 1809? Are you on the latest SteamVR for WMR app from Steam?

I just have my icons direct in Cliff House now, and don’t even bother with the SteamVR step.

Anything you run in SteamVR is available in the ‘Application’ menu when you press the ‘Windows’ key on your controllers.

Ah yeah…I have my Aerofly FS 2 icon in the Cliff House…I have no idea how I got it there. LOL…otherwise I would probably have the rest of mine there too.

I’ll talk about DCS as that is the main sim I am using it for (closely followed by X-Plane).

The resolution doesn’t seem great. Trees seem somewhat pixelated.
If I look off to the side, trees and buildings ‘ghost’ as if there is a partial double image. If I roll hard it becomes a blurry mess until I ease up to a slow roll rate.

With the Rift I am not seeing this, or at least, nowhere near as badly.

It is like I really need ASW, or the SteamVR version of it.

2 Likes

If you’re up for it we can try a few things. Once these are all set then I’ve found it doesn’t get much better.

  1. Make sure you are on Windows 1809 by going to Windows Update and check ‘OS Build Info’.

  2. Make sure you are on SteamVR 1.2.10.

  3. Opt in to the ‘Windows Mixed Reality for SteamVR’ beta here: (right mouse button - properties on your Steam library entry for this):

Now set your SteamVR bits just the once:

Put SteamVR to a Manual Override of 200% so it looks like this:

image

Check your DCS is set to 100% in ‘Application’:

image

Check your other settings to look like this:

image

Put DCS to a Pixel Density of 1.0 in DCS settings, and as I have a 1070 try starting with some low settings like this:

If you change the DCS settings then do delete your Users \ (your-username) \ Saved Games \ DCS.openbeta fxo and metashaders2 folders completely with DCS shut down, and then restart it.

If after that it still seems unclear then it might be worth trying this, as it’s a DCS specific alignment bug and I’ve had good success with it.

It might be the case that the fit of the device is not good for you personally, in that the sweet spot of the lenses doesn’t work for you.

4 Likes

Thanks Fearless! I’ll work through those steps now.

Step 1… I was on Windows version 1803 so I’m forcing the update now.
Step 2… Steam VR is Beta 1.3.18
Step 3. Under Applications, DCS isn’t listed.

1 Like

Cool - Microsoft did a pretty stupid thing and put the Windows Mixed Reality driver updates as part of the Windows release cycle. For new tech that was just a terrible idea. From 1809 onwards the updates come separate as part of the Microsoft Store set-up, so thankfully this is a one-off.

With all this, don’t get me wrong, in that I think WMR is not good out of the box, there is far too much pain involved in getting it to work that should not exist. Oculus is far better like that, and Microsoft could learn a lot from it.

When it comes to anything game related with Microsoft and PC gaming, it is like they get the guy from Office in a suit to think about the usability rather than the t-shirt wearing Xbox person. I think there are people still traumatized by ‘Games for Windows’ to this day… :slight_smile:

2 Likes

That should be ok, it’s because I had it as a ‘Steam shortcut link’ (where you add external apps to your Steam library) and SteamVR just uses that if you want to override settings. It should default to 100% if you don’t have it.

1 Like

Great… ok, well I just have to wait for the Windows update to finish downloading… I guess it is quite sizeable… I’m at 20% now. I greatly appreciate your help walking me through all this!

3 Likes

Hmm, updating to 1809 caused some issues. It introduced some stuttering with DCS. VR was pretty much unplayable and it was not good in 2D either. Very strange.

I have rolled back to 1803 and everything is smooth again.

How do you move them?
And can you start non steam games (like my DCS version) trough steam?

Strange! Cause that update imrpoved lot of things!
:face_with_monocle:

1 Like

That is a shame. :frowning:

The only thing I can think of (and I don’t recommend going through the long update again, especially if it’s ok now) is that perhaps some of the ‘XBox Gaming’ stuff got turned on in Windows 10, with the ‘Game Recorder PVR’ especially being known for causing pauses and lag. https://us.battle.net/support/en/article/92046

The next windows update is due June ish (1H 2019), so they’ll be auto-upgrading everyone to 1809 (1803 is from April 2018), so something to try if they do force the update.

Just press your ‘Windows’ button on your controllers and in the ‘Apps’ menu anything that you’ve got installed or have run through SteamVR will appear, and then you just select it to make it a ‘3D tile’. Resize like this:

I don’t think so, but what I do is just have an enormous ‘Desktop’ 3D tile in my home when I arrive, then I click it and just double tap the DCS icon on my desktop - works pretty well.

2 Likes

I’m giving it one more try. Now the update is downloaded it is a quicker process, and reverting to 1803 is a fairly simple process.

1 Like

OK, well, some success. After applying the Windows update again, I discovered that the Intel Turbo Boost Max software had turned itself on. That turned out to be the cause of the stuttering.

I then was able to get a fairly good experience out of DCS in the O+. I then forced on reprojection for WMR, and that really helped smooth things out.

So now I would say I have similar performance to the Rift. Not quite, but close, and definitely usable for DCS. Thanks again @fearlessfrog for your patience and assistance!

6 Likes

ty! solved!

1 Like

!!!Internet Rumor Alert!!

There’s a guy on reddit (people wouldn’t just go on reddit and lie, right?) :slight_smile: that claims to work for the HP VR team and has confirmed the following regarding the HP Reverb:

  • Available Late April.

  • Available in Europe (for sure the UK, Italy, EU)

  • Uses DisplayPort connector rather than HDMI

  • 3.5 meter cable (that’s six tenth’s of a hogshead for you imperialists).

https://www.reddit.com/r/WindowsMR/comments/b6mh6o/im_totally_sold_on_the_hp_reverb_does_anybody/ejlvhjr/ https://www.reddit.com/user/Voodooimaxx

3 Likes

Display port? Not that new fangled USB-C advanced port?

1 Like