Our Samsung Odyssey (+) first impressions, tips, and tricks...

I’ve been hearing a lot about bumping up SteamVR resolution to 200%, but when I tried it I kept getting “crashes” (not actual program crashes) to the SteamVR screen while flying the Tomcat, so I went back to 100%. I haven’t tried a PD of 2.0 yet. My one complaint about the image in my O+ is the fuzziness of everything, especially on the periphery. My second complaint would be the awful forehead chafing from the front pad of the goggles, which is the only part making contact with my head in the front. The larger, upper-front pad won’t contact my head at all.

1 Like

firmware update i’m on 1.0.1 and got invited to update to 1.0.2

inside Samsung HMD Odyssey+ Setup

headset is working flawlessly
i’m from Europe so i have no idea how much assistence i can get if the firmware update fails…

what version are you on?

no changelog anywhere TY samsung!

seems they changed something to the ipd
also some report trouble uploading it. (you need direct connection to pc usb3 no antivirus running etc…)

The number is being used to render the VR perspective. If the IPD used to be 63 but now it’s 60 then it makes sense that thing would appear bigger (your eyes are closer together now). This is great.

1 Like

Yeah, not sure that that was about but the update went ok for me without turning off AV or anything. I had a quick look around after the update and it seems pretty much the same.

Once I started the ‘Samsung Set Up’ app (which I never go into, after from first install) it offered the update and a I said ok.

The sweet spot size is sort of connected to the comfort, in that if the headset doesn’t fit your head very well then it’ll be blurry or have a very small clear area. I know that for a few people the O+ is really uncomfortable, and that Samsung didn’t really do a good job on the fit. The only advice I have (and this might not help depending on the shape of your head) is to loosen it so that the band at the back is quite low on your head (like where your head meets your neck at the back) and then tighten it from there.

I tried placing the back portion of the ring low on my head and tightened, and I also tried wrapping a small towel around the forehead pad, but alas both attempts just made a massive 1" gap between my cheeks/nose and the HMD.

I don’t have one, but @BeachAV8R uses a plushy face cover here - Odyssey Plus replacement foam from VRCover

I’m probably going to have to (well, have to is a little strong :slight_smile:) get another headset this summer, and I’m running out of kids to donate the existing ones to, so ebay is beckoning for me.


I can’t remember if I posted this before, and search shows nothing, so thought I would share.

If you have a system where you don’t reach 90 frames per second then you’re going to either just get repeated frames with reprojection off, or you can enable reprojection and get some automatic ‘in-between’ frames generated (based on your head movement).

What I hadn’t tried before was playing around with the refresh rate of the Odyssey Plus, just to see if that did anything interesting. As ‘half refresh rate’ is used to decide if reprojection is used or not, it might be fun (‘fun’ not guaranteed, no returns).

In your WMR app, you can use ‘Settings’ from the ‘…’ menu on the bottom left (cool name Microsoft btw … ) here:

From this you can get to the ‘Headset display’ sub menu here:

The beautiful rendering of the ‘2’ shows the ‘Change’ button to be able to switch your headset from ‘Automatic’ (90 Hz) to a manual setting of 60 or 90. Once you’ve changed it to ‘60’ then manually close and restart the WMR app.

Now, check that your reprojection settings are on by notepad editing the ‘default.vrsettings’ WMR file here:

X:\Program Files (x86)\Steam\steamapps\common\MixedRealityVRDriver\resources\settings\default.vrsettings

Here you can see I removed the ‘//’ characters from the ‘motionReprojectionMode’ and ‘motionReprojectionIndicatorEnable’ settings (the latter is used as an indicator that reprojection is being used, you show see two blue squares on the top left in the headset - just put the // back if you like the reprojection settings, as you don’t need the indicators all the time):

Save that file and restart WMR.

So, how does it do? Not too bad, easy to try and put back if you don’t like it. One thing immediately noticeable is that the beautiful bright display of the O+ looks dimmer to me. Maybe about 10% darker? Not sure.

In DCS, the frame rate is now locked to ‘30 fps’, as the reprojection is automatically taking it to 60 Hz / fps in the headset. What this means is that your ‘target’ for DCS is now not getting to 45 but getting to 30 fps instead. This can sometimes help a lot, especially if you’re not running a 2080 and use oversampling to make the display clearer.

Anyway, I personally just strip off stuff until I get reliable 45 fps and then put the HZ back to 90, but thought it would be interesting for others to try, especially if their systems struggle, or stuff like X-Plane (which always has trouble with framerates) is used.


Thanks for sharing frog man. I’m finally at a very stable 45. Tried turning it off and the fps varies too much and I didnt like it. So it stays on for me. I’m running a 2080ti and an 8700k so I’ll keep it here. Others might benefit though.


Hmm, that looks comfier. I tried flying with the back headband lower and the forehead pad actually on my head. It was quite comfortable, but due to the angling of the actual “visor” the entire lower half of my FOV was blurry, making it impossible to reference my instruments while flying without going heads down like the old days of TrackIR.

WHOA! I was Wrong Wrong WRONG! Lowering just the Hz to 60 instead of 90 gave me a HUGE BOOST. Instead of running around locked at 45 fps now I am running at a constant 60 with MR off of course. Will turn it on tomorrow and try again but this is just amazing.

Great Find! And Thank You Fearless!


I’m going home soon. If turning on Reprojection and running the game at 30 fps makes it smooth, so be it.

I think if you can make a constant 60 fps at 60 Hz then you probably don’t need the reprojection.

Thanks Fearlessfrog. I’ll stay with what I got then.

Just had a go at Il2 BoS. Never went below 60. This is the fix I’ve been waiting for.

1 Like

A sound settings tip. I didn’t know this but the Odyssey Plus have improved spatial sound 3D headphones. Trouble is I’ve never actually turned that feature on, and I’m guessing most people haven’t either. To set ‘Spatial Sound’ in Windows 10, right mouse click your taskbar sound/speaker icon and you’ll see this:

Select the ‘Windows Sonic for Headphones’ rather than ‘Off’. Good old Microsoft, with ‘Off’ as the default setting while wearing the headset. :roll_eyes:

You’ll now have 3D spatial sound in the AKG in-built headphones.


Il2 GB is really good now. I fly lots of Axis. Mostly 190. If I tried to boom and zoom before I would lose my opponent and usually the fight. Now its different. Not only is it super clear but I can keep up with contacts for quite a distance. I’ve been having a great time thanks to @fearlessfrog and his settings and fixes. 60 fps is the answer for me. So clear and no lag. I’m finally playing on line. YES!


And follow this…

1 Like

just tried it!

mine is on by default :stuck_out_tongue_winking_eye:

Going through the nuts and bolts of configuring on a new system. Can someone refresh my memory - are we still adjusting SteamVR to 200% or leaving 100% and adjusting per game?

Also - I selected in Mixed Reality Portal > … > SETTINGS > Headset Display > Visual Quality > Very high (beta) - that sound about right?

I haven’t messed with that ini file thing yet…

The ini file has good defaults now, so no need for that anymore. If you want to you can enable reprojection in that file, but considering Iran would probably like your PC for national centrifuge control or working out the lost digits of PI, then I think you’ll be alright with it off. :wink:

I personally still do the ‘200% manual override’ and just leave everything else at the 100%, PD 1 etc. That was of course when I had a working computer capable of flight sims (sniff, sobs, sniffs a bit more…). I bookmarked that steamvr settings post here.

The ‘Visual Quality > Very high (beta)’ just does the WMR apps quality I think, of which I think the only one in existence might be the ‘Cliff Top home’ thingy. Can’t hurt though.

1 Like