Q about Rift S - looking for solution

Hi all,
Tried opencomposite for IL-2 BoM, didn’t work - different topic for another day. Removed opencomposite, steam as default BUT now DCS and Elite Dangerous (and some car sims) do and do not work in VR.
Do work because the programs load to completion,the display on the monitor says everything works as advertised, display on monitor follows tracking/movement of headset whilst held in my hand, sound coming through Rift S speakers.
Do not work because the Rift S just shows a loading screen forever.

Rift S works as advertised on SkyrimVR, GoogleEarth,Robo Recall, so it is not a hardware problem.

At direction of Oculus I have uninstalled and reinstalled Oculus software in safe mode and whilst not connected online. Have also uninstalled/reinstalled Steam and ED, no joy.

Thought I might tap into the hivemind of Musdpike…oh, I also wanted a funny red hat .

Thanks, John

Can you be a little clearer regarding what is running under Steam and what is not? In my case I only run IronWolf VR, Elite Dangerous and VTOLVR under Steam—because of course I bought them through Steam. My IL2 install was not bought through Steam but it runs under Steam VR. I have had your problem before but when I did, it was universal to all games and was fixed by unplugging/replugging the headset. Your case is not one I have experienced but it seems like a conflict between SteamVR and Oculus to me.

If I was in your situation, I would uninstall SteamVR and recheck all the titles that are not Steam dependent.

1 Like

I use IL2 standalone, but I have to open steam vr and oculus first. Did you check the “enable VR headset” option in the IL2 launcher?

You could also try updating GPU drivers. If you are running an AMD card, their latest driver is screwing with rift s and they recommend a roll back.

Did you set opencomposite back to SteamVR, before uninstalling it?
Have you tried uninstalling and installing SteamVR?

Hi fellas.

Hey Troll, yeah I made sure I did that. It’s my understanding that opencomposite is fairly clean ie just delete folder as it doesn’t mess with the registry, but I’m not overly experienced with this stuff.

Hey gunny, rolled back nVidia drivers to a date when things worked, in this instance I used 436.48. Saw you referred to AMD, but I’m open to all options.

Hey Eric, after I uninstalled Steam and all it entails, I tried running DCS as that was never purchased through Steam, likewise with IL2, that was purchased direct from 777, No go. I have a few Steam titles that work in VR as advertised. I could uninstall DCS and all the modules, but I’m wondering if a clean install of Windows 10 would be cleaner as I suspect there is a conflict higher up the chain. I’m rather stumped.

Many moons ago this would have been challenging/thrill of the chase/I will beat this yada yada, now I just want it to work/get off my lawn yada yada

Thanks for your replies guys

1 Like

I guess the fact that you never got opencomposite to work, is a hint here. As you say, it may be a higher level problem…

1 Like

Im guessing there is a lingering registry issue with opencomposite, or steam VR is not working properly. If the headset works on Oculus software, its not hardware related. You said you have a few Steam VR titles that are working also?

If I’m following you correctly, the only titles that arent working are IL2 standalone and DCS standalone. If that’s the case, I would say that opencomposite is somehow causing problems from the grave. If you are open to it, a clean windows install would probably fix your problems.

Here is what I would NOT bother doing: Uninstalling and reinstalling game x. The hours such an exercise will take will be hours of your life you will never get back. That Rift S works within the Rift world but DCS does not is totally weird. If @Troll and @Gunnyhighway are right then your only recourse might be to reinstall opencomposite just so that you can properly delete it. I have never tried opencomposite so I don’t know the workflow. I can say that my experience with Oculus has been three years of almost worry-free/fiddle-free enjoyment. So while I can’t really relate and can’t really help, I do understand the frustration.