Reverb G2 no image in VR

Hi everyone,
I had a problem with MSFS and VR not getting anything but black screens when going to VR.
I tried everything I could think of and googling every possible solution and trying every order in startup but nothing worked. This ended in me getting a refund with Steam.
However since I can see that it works for other fellow simmers I can’t help thinking I missed something.
All other sims (Falcon4 BMS, IL-2 and DCS) works perfectly both in SteaVR/WMR and OpenXR.
So my question is simply if anyone has an idea what might have led to my problem and perhaps I will get it again but this time from MS Store instead.

I’ll start with the easiest one. MSFS requires the user to hit Ctrl+Tab to enter VR. Was this when the screens went black?

1 Like

Everything works perfectly outside VR but upon switching to VR view all goes black.
The headset is identified properly and the screens are displaying but the image is black.
Tried all different suggestions found in forums in the order of starting everything.
Also tried with binding differnet keys for both recenter and switching to VR.

Probably not relative, but back when I was using a G2 with the Steam version of MSFS and switched to the OpenXR runtime, I never launched SteamVR before launching the sim.

Interesting, I have been contemplating that Steam involvement might be a reason in this case but I tried launching from desk shortcut aswell and letting the sim do it’s own thing choosing the order of startup. But I’m still not convinced that Steam was the factor of error in my case and thinking about getting it via MS Store to try again.

Not MSFS specific but I have found that the G2 can be a fussy b… with the order that apps load, Discord in my case and maybe with other background apps? Maybe try disabling everything that is running in the background that you can and see if that helps?

What I had to do to get DCS working with Discord was:

  1. Start Discord
  2. Connect headset and let WMR autostart.
  3. Launch SteamVR
  4. Launch DCS

That was until 2.8 and native OpenXR support, so now I am bypassing SteamVR. Website below had some tips that got me sorted.

@MA_Goblin, which is the default OpenXR runtime, SteamVR or WMR?

WMR, running DCS in forced native OpenXR and IL-2 OpenXR via .dll file in game folder.

Will check that, been a long time since I viewed Thud’s page

Back on topic to MSFS, as he said that DCS VR is working.

Do you have OpenXR Tools for Windows Mixed Reality (not OpenXR Tool Kit) installed and updated from the Microsoft Store?

Screenshot 2023-02-16 101632

If so and on the Settings page you have under Preview Runtime, have Use latest preview OpenXR runtime toggled on, you can launch MSFS from either the icon or in Steam.

Do not start SteamVR. Once in MSFS, use CTL+TAB to toggle VR mode.

MSFS should use OpenXR as the VR runtime and all should be good. If SteamVR is running, it will conflict with OpenXR.

Have it installed and updated and settings as stated.
I did not start SteamVR.
Starting from desktop icon or Steam didn’t make any difference.
When switching to VR view all is black.

1 Like

Copy, good to know that you’re doing the correct process. Since it seems to be working with other sims, logically it would point to a software issue. I don’t think that it is a Steam store issue, since so many are not having trouble. Next, I was going to recommend doing a Steam repair of the install via Verify integrity of game files… function, but impossible if you don’t own it. Good luck.

1 Like

Have you tried setting SteamVR as the OpenXR runtime?

That I did not try.