RTX 3090Ti no joy with Reverb G2

Hard to believe, right? Took advantage of the recent sale to purchase an EVGA FTW3 Ultra. Beautiful card, which runs cool. But…doesn’t work the a G2 or a G1. Not vendor specific BTW. So this morning I grabbed the kids Quest2 and get back up to speed with all things Meta.

Is it factory overclocked?

That’s too bad. There must be a way though, right? Both the card and the headset have been around for over a year. As for me, after I installed my 3080ti, X-Plane would only run in OpenGL (no Vulcan or Metal). But after running the latest drivers from Nvidia, it eventually behaved itself.

1 Like

What kind of problem are you having? Isn’t it the (in)famous usb connection? We discussed that one here on Mudspike as well.

I had that usb problem too but solved it eventually.

The error is 1-4, check display cable. That sent me in a 2 hour wild goose chase juggling cables. It’s a know issue to Nvidia and HP. So far, they haven’t solved it. Plenty of discussions about it.

I haven’t overclocked the card. Just default out of the box.

1 Like

No, but is it factory overclocked?
Just trying to rule out possible causes.
What kind of mobo and cpu?
It worked on the old GPU with the same mobo/cpu combo?

Also worth checking the cable connection to the headset. Any chance that may have wiggled out a litte?

1 Like


Compatibility between GeForce RTX 3090 Ti and Certain VR Headsets



1 Like

Before I answer these, the problem has been known to Nvidia and HP engineers for around 4 ,months, judging by their responses in various forums. Reddit HP Reverb forum has a good thread on it.

  • The Ultra does run at a higher clock speed that the run of the mill 3090 Ti, but they have the problem as well.

  • Asus Mobo and Ryzen 5600X

  • It worked perfectly with my RTX 3080. And the 3090 TI runs perfectly with a Quest 2 and Link cable (USB3).

  • I troubleshooted the headset for 2 hours. I tried the original cable, different ports on the card, removing my monitor and only having the G2 connected, and tried my G1. I checked the connector at the headset maybe 15-20 times.

Rebooted a number of times, tried older drivers, and finally gave up and started searching. I had cables and headsets scattered all over my home office last night. Should have bailed early and used Google in the beginning. Probably like most of you, thought that I was doing something wrong.

To quote @HiFlyer’s link above:
"NVIDIA has identified a DisplayPort connectivity issue between certain VR headsets and our GeForce RTX 3090 Ti:

  • Oculus Rift S
  • HP Reverb G2 (with G2 cable) and HP Reverb G2 Omnicept Edition (HP Reverb with G1 cable is not affected)
  • Pimax 8K X DIMAX
  • Pimax 5K Plus"

You know what I didn’t try was G2 with G1 cable. I tried the G1 and the G2 with G2 cable v1, but not G2 with G1 cable.


Never mind. The G1 and G2 cables are a completely different connector on the headset side. They look similar, but the G2 is quite a bit smaller.

Ok. Never had a problem with my 3090, besides those associated with AMD mobo chipsets. Guess this is unique to the ti editions…?

Yes, unique to the 3090 Ti.

BTW, my HP Reverb G1 doesn’t work. Same error. I tried plugging it in all of the 3 DP ports and both onboard and powered USB 3 hub. No joy.

Since I moved from 2080TI to 3090, I will get Windows Mixed Reality connection error with G2 after every computer start. Good thing is that in my case this can be resolved by powering the goggles off and on (using the button in cable) while the error is shown in Mixed Reality app. This resolves the error.


Frustrating yes. I had same error with my new PC (ASROCK MB, AMD5900X, G2, 3080Ti). I tried every port (usb) and found only one that worked, intermittently though. Updated stuff (BIOS, drivers, etc) and it’s worked fine for months. All I’ve got.

1 Like