Server dont start

I have no IP on the server dashboard. Restarted pc ect ect … no joy. Please help
DCS starts and runs fine. This happened after I did some debloat program. My weekend is going from bad to worse…

1 Like

Can the server see the network card?
Can you ping your ISP?
Have you tried praising the elder gods?

1 Like

As well:

Run the DCS repair just in case.
For the dashboard, hard refresh with Control+F5.

After that, DCS.log file would be the next source of info on where to look next. We want to see the info as it tries to bind to the network device & address, connect to DCS master server, etc.

Machine is on the network. When I run the server gui there is no IP on it. Thats the problem.
Ran repair and made sure DCS was working in multiplayer.
Im going to try the prayers next

If you can actually connect to the server to play, then what you may have is an issue in the configuration somehow where the WebGUI port has changed or it can’t read that value. Again, DCS.log may have the answer. As well as the server config and see if there is anything out of place there too - an errant space or missing comma could throw the whole thing off.

If I remote to HPN, and tell my WebGUI to try port 8089 (intentionally wrong here) it fails in the same manner as your screenshot.

The server IP info can’t populate unless it can connect to the WebGUI which in your case is failing.

Network should not affect the WebUI as it’s using loopback / localhost.

Another issues that can totally break the WebGUI is browser security settings. If you use Chrome, hit F12 for the console and get to the Console and tell us if there are any errors there. I don’t recall the exact error off the top of my head but I’ll recognize it if I see it. This caused a big issue for Windows Server users but can also affect Windows 10.

I found the console to Chrome and it says, "Console21301: service Worker .get Registration is rejected due to host restriction ect /Eagle Dynamics / DCS world open beta.
I went to Norton and Norton says its allowed
Pulling hair out

Screenshot that full error from the console, even if I induce a failure I don’t get that.

Do you have other browsers to try? Edge, Firefox, etc?

Youll never beleive it! I had gotten rid of Edge. Once I updated Edge…Walla!!! Server works.
Thanks for your support Wes.


Chrome is Google’s adaptation of the Chromium project which I think they more or less sponsor/control (I forget) - Chromium is open source. Microsoft abandoned Edge & making their own browser engine and new Edge is Chromium based. So basically Chrome, with a Microsoft skin and integration instead of Google. Useful backup browser now.

1 Like