(SOLVED) rudder pedals not recognized in Steam

this is a copy of what i posted on redit, and i hope you do not mind putting the same message here again. Let me know if things are not compatible.

This problem is solved, but I had a hard time figuring out what was going wrong, and others might also find this solution useful. The issue: my Virpil ace rudder works perfect with DCS (standalone). But was not recognized in steam: in ace combat no rudder device showing up in config.ini.

A guy at the Virpil site mentioned that steam requires a full joystick, so all three axis, for input, otherwise it doesn’t understand the inputs. Solution: add two axis in your rudder software. Easy as that. I added an additional x-axis and y-axis, but with no real bindings. Save, update and reboot service, start steam and check config.ini. now it should show the rudder! Assign proper axis property (z-axis for yaw) and remove this axis from your potential other devices. Restart steam, have fun.

In my impression this approach might also work for other controllers not showing up.

Credits go to cynrain .Thanks. :pray:t2::relaxed:


Mooi werk, good job.