Steam Disk Write Error

Happy New Year!

Well mine is starting on a low.

I have gotten my last 4 TB HDD and it is installed.

I keep on getting Disk Write Errors when installing or updating Steam games.

Very annoying!

I am slowly moving through the cure steps mentioned here, but so far nothing is helping:

https://windows10skill.com/16-ways-to-fix-steam-disk-write-error-on-windows-10/

I have a very hard time believing that it is disk failures. If it was one of them maybe, but it is all 3 new drives.
I think that it is either something in Windows 10 and/or Steam that is screwed up.

Well I cleared the download cache, so now I have to download all the newly bought stuff again.

Boy I hope that the repair library is working.

Well have a Happy New Year!

2 Likes

I managed to get a faulty disk once, then the replacement i got was faulty as well. It’s not that uncommon.

Do some kind of SMART value test and see if you got faulty sectors.

2 Likes

Might also be the controller on the motherboard or even the cabling and seating. Sure does suck, doesn’t it?

2 Likes

I ran into this issue awhile back and the fix for me was re-installing Steam (making sure to delete any leftover files or installing to another drive). If you install your games to the same folder then backup/move the “Common” folder.

This included recreating the manifests etc. on any game install drives by letting the new Steam install create a new Folder structure.

You shouldn’t need to download the games again as long as you save that common folder.

The good news was it wasn’t hardware in my case.

2 Likes

Statusreport:

sobek
I have made a surface scan with Partition Master Pro on my 1 TB Win 10 system partition and on one of my 4 TB data disks and neither of them had any bad sectors. I am ruling out faulty disks at this point. Close to 11 hours. Blarh!

schurem
It does! Very much indeed!
My thinking is that if it was the controller and/or cables, then errors should occur when working with other stuff. It is only happening with Steam downloads.

Hardtale
I think Steam is the problem so now I am moving all of my downloaded games into a backup folder on the tested data disk and then I will uninstall and reinstall Steam.

3 Likes

And I’m up and running again! Wheehaaa!

Some of the old files worked but I did have to download 122 GB. There where no errors whatsoever.

I’m a very happy boy!

5 Likes
© 2019 Mudspike.com | Articles Website | Forums Rules & FAQ