Strange controller problem in IL-2

I tried IL-2 Great Battles again, after installing the VPC setup, and my RTT companion controller.
When starting IL-2 I got a question if I wanted to transfer controller assignments to my new controllers. I declined, and thought I’d be better off just reassigning the controllers myself.
The controllers were assigned in the settings, but they won’t work in the sim.
I mean, they register just fine when assigning them, but when in the cockpit, nothing happens…

Anybody heard of anything like this?

Evidently IL-2 gives every new controller a unique ID number. But any ID above 8 is not recognized in the sim. Not a problem for most users, but definitely for users like me, who build and swap controllers.

Solved the problem by deleting the entire input folder. That forced a rebuild of the controller devices and assignments.

Now the devices were numbered from the beginning again.


I am glad I could be of help. You’re welcome.

1 Like

Yeah, thanks man!
This has tought me a lesson. Always ask @smokinhole first. He will know what to do.
To think I posted a question on a forum, like a total noob… :man_facepalming:
I really owe you one.

1 Like