Technology and MSFS

In my case MSFS doesn’t work. Since I got into helicopters I haven’t flown MSFS and it has changed a lot with many updates. Not only that it now has some unofficial helicopters. I cannot make my controls work however. I have followed the advice on youtube videos and comments on the net.

Help would be appreciated

I have a Virpil stick and base, an x56 throttle, K51 collective and crosswind pedals. I can make the VR work but not the collective, stick or rudder.

1 Like

have you tried using 1 peripheral at a time?

start with just the throttle plugged in, load Msfs and see if it recognises it, then plug it in WHILE its running.

move to another one until something possibly happens. it may help you find a conflict that you arent seeing with all plugged in.
try taking any usb adaptors or hubs out and plugging in directly.

disable any other programs like VPC mapping or similar.

update any drivers,

did it do it on your laptop and the new pc or just 1?

1 Like

They are all recognised. An example problem: Move the stick forward, the Cessna 152 does nothing until it is almost fully pushed forward then responds very slowly. The rudder pedals do next to nothing. I have tried legacy, sensitivity etc. It worked ok on the laptop, not the pc but it is a year since I flew it. It appears an msfs mod screwed up some settings on controls

1 Like

do all controls do the same thing? i.e respond sluggishly at full rudder input etc?

any double bindings? not really sure other than that

Sorry to hear. That’s the sort of thing that can drive me mad(der).

It looks like you tried some of these, but just to cover all the bases…

Out of curiosity, perhaps it would be helpful to isolate the issue by input.

  1. In the windows controller settings, are all axes recognized? Do they move normally and do perhaps any of the other hats, sliders, rheostats (even on opposite controllers) ALSO move the axis?

In some Steam games, my right toe brake seems to equate to the Up/Down keys. I must hold about half brake to change my keyboard assignments. I’m guessing it must think that it’s an XBox controller. :man_shrugging:t2:

  1. In MSFS controller settings, same thing. Do the response curves move freely and throughout the entire range? If you can set those to default, maybe give that a try in case somehow a big deadzone or steep response curve got assigned?

  2. From the external view, what do the control surfaces do? Do they move, but barely, do they twitch? Do they match the plane response or the control input? Does the issue happen on every type of aircraft?

  3. You say a mod might have messed up your a
    settings. Did you drag your community folder clean and see if that changed anything?

If your gear works outside the sim, my first thought would be a binding conflict. My friend had one and he cleared all his controller assignments and started from scratch. The fact that you have mismatched gear and likely quite a few extra axes (The twist throttle on the collective made me wonder…:thinking:) seems like it could be a possible source of trouble?

Unfortunately in his case, I think he was having some joystick issues with an old Saitek. He went full up Virpil and had no issues thereafter.

1 Like

Problem sorted.

One of the things I love about DCS, the best thing in fact, are the really helpful people I meet. A nice German gave me an hour of his time this morning, watched me stream my screen and worked out where I had gone wrong. Thank you @Nostro, German LLH helo pilot.


In the interest of future people finding this thread, perhaps through Google, could you tell us what the problem and the solution was?

AnyDesk works really well too. Easy to use.

Nostro knew what he was doing, I did not. First he had me delete everything I had done. Then he had me bind keys. My efforts at sensitivity had screwed up the axes on the flight controls. Guess you tube videos dont all work well as a teaching medium.

1 Like