TM WARTHOG slew control upgrade

My Christmas allowance will be equally split between 8 more GB of RAM and (probably) this mod.
Eventually I’ll also buy the MFG crosswind…

Oh look what came in the mail today…


Please let me know your thoughts. I’m really interested if it feels more precise when locking targets on radar or as a Mav slew control.

It’ll be next week before I can install it, because Turkey Day, but I’ll let you know. Planning to have it up and running before the fly - in, so I’ll have one less excuse for my crappy weapons employment.

1 Like

Yup, looking forward to your report Sir.

Having been using this for a while now, including with the recent hornet ir mav update, I can say that absolutely yes, it is far smoother than the stock ‘eraser nub’.

To me this is a must have mod for the warthog.


Thanks! So it offers both the 4 axis and a push press right?

Yes! All input functionaily is kept from the ‘eraser nub’!


I am coveting this. Even stronger than an extension or proper seat.

I am too, although for me an extension is of equal covetedness.

Finally got mine installed tonight.

Work area set up.

Boca decided to supervise. And judge.

I didn’t have any issues with any other connectors pulling out, possibly because after reading Fridge’s experience, I was being extra careful.

Sensor installed, getting everything buttoned back up.

Next up: calibration.


…aaaaaaand it’s not working. I’ve got the button press, but nothing from the axes. Email out, let’s see what I did wrong.

Did you run the tool afterwards?


Unplug, replug?

EDIT: Oh and firmware on the Warthog, replug, then calibrate?

Yep. Twice now. Tried turning it off and on again, and I’ve already emailed Damien, so we’ll see.

The firmware was a thing for me. Getting it updated was a bit tricky. I remember having a similar issue where the axis didn’t respond, I tinkered with it and then it suddenly did. Can’t remember if it was replugging (you tried that) or the firmware.

1 Like

Not sure if it’ll help, but as Fridge said, make sure you’re on Firmware v23

That’s really the only thing I can think of.

1 Like

I did this last night, too. My firmware was upgraded a few months back. I ran the included calibration tool and got a Success result. All looked fine in Windows. It was late, so this morning I will give it a go in DCS.

I also shaved down my afterburner detent so the throttles can be pushed forward.

Good luck on your ustick, Navy!

edit → all is goodness with the new microstick. The throttle is working super with the new slew control and afterburner detent change.


Two uninstalls, one bootload, and two firmware reflashes later, and it’s all up and running! Success!