Trees not the same in left and right eye? DCS VR


No such a problem here.

Did cleaning the shaders help?

Thanks for the quick replies, cleaning the shaders did not help. I can clearly see the most distant trees rendered are much bigger in the left eye than in the right. Used Mi-24 Caucasus Free Flight instant action to test.
I cleaned up all directories referenced in this script:

Lines 37, 43, 44

Now going to re-install WMR for SteamVR

1 Like

Tested with F-15 free flight in Marianas this time, since that map’s shaders had not been re-built yet, and same result. I can see trees about 100-200 meters further out with the left eye. So, which config files did I change back when I had the Odyssey?
The search continues…

Had a look myself, and I can’t see any difference…

It is nauseating, you would have noticed. Must be something specific on my system. Just realized I am running that modded DLL for AMD FSR, let’s try without that.

No luck either

1 Like

These files seem suspect:

I was able to find them after finding the original Mudspike topic. Let’s remove them and see what happens.

EDIT: Still no cigar!

1 Like

I am not sure what the next reasonable step is:
re-install WMR Portal? Or DCS World?
Something else?

On the upside, I will be away from my pc for a week starting tomorrow probably, so we have enough time to brainstorm :smiley:

Try WMR portal first… Then maybe a DCS repair?

1 Like

I occasionally have the same problem with my Reverb G2. Also happens with smoke sometimes. Seems to be rather random, and if I notice it and reload it goes away.

1 Like

Just a shot in the dark but might want to try this from the DCS forums: WMR DEBUG TOOL - cross eye alignment - Page 5 - Virtual Reality - ED Forums (

1 Like

That’s a good thought, and could be the issue, but it doesn’t seem like it. I’ve had the alignment problem with my old Odyssey Plus and had to align it following the guide, but the Rift S and Reverb G2 have been perfect (seemingly anyway) out of the box. Scenery such as buildings, ships and the cockpit itself seems to be fine, but some ‘autogen’ scenery such as trees and chimney smoke often only appears in the left or right side alone.

1 Like

The only other thing I can think of is uninstalling all mods and running a repair on the DCS installation.

1 Like

Thanks for all the replies! I just packed the Reverb G2 back into the box…

To take it with me on vacation to the inlaws! They also play flight sims, but don’t have VR, so fun to try. That GTX 1060 will be sweating it though.

Mostly, they just bought an Ender 3 3D printer so I am hoping to print a modded gasket to bring my eyes closer. There are tens of designs on Thingiverse. As I have been using it, I have had to push the cushion into my face so hard to get to the sweet spot. So a thinner gasket should fix that.

With all of your help, I will have enough things to try when I get back. Sorry in advance for keeping you waiting.

On the upside, the box still smells of lavender and new cables :wink:


I run the repair and delete shaders occasionally for other issues, and still run into this every now and then. Restarting DCS seems to fix it. I assume it’s a bug, it used to affect the clouds too but the new clouds seem to have fixed those for now.

1 Like

So I just had this issue on the Marianas, and noticed that when I turn the forest visibility (distance the trees spawn in at) either all the way up or all the way down it goes away. It seems to be something to do with the LOD and one eye possibly being slightly further away from the object than the other, maybe?

Anyway, now I’m running that setting all the way up and seemed to fix it. Of course I can’t test it any further yet because my PC crashed again a minute ago… finally have time for DCS (paternity leave this week :rofl:) and my PC is giving me fits with BSOD’s. Aw well, I probably need to be helping the wife anyway instead of playing games.


This might be the same issue, it’s caused by a WMR setting I probably changed:

Fixed : "In the WMR settings for Headset display under experience options if you have it set to Optimise for performance you get the object desync. Set it to Best visual quality and it works as it should. " found by user Dayglow


Wow thanks @WarPig , great find! I did indeed change that setting, though I had forgotten about it. I will let you know if that works in a week, but this must be it.


A prime example of a ‘community wisdom’ :+1: :+1: :+1:


1 Like

If there are issues persisting, have you checked frustum culling? The autoexec.cfg in Saved Games Config folder has this line: = true

When true some people have reported objects being rendered differently (or not at all) in one eye.

Man that sounds like something that would make me flinch if the doctor said it during an appointment. :laughing:

I will check this next time I have a chance and report back. Thanks!