Upgraded my gaming rig; hosed both of my X-Plane installs.

Executive summary: I replaced my 3 year old mobo, cpu, and memory. The process took a day, because I have a very compact Falcon Northwest Fragbox. However, once I had the little beast back together, Win 10 booted, and other than having to add license keys due to major hardware change, apps and games have been working great.

That is except X-Plane, both my production and beta instances. I have been troubleshooting it for a week now without resolution. At first I thought that it might have been license keys, and then disk issues. I finally broke down and wiped my production install. Even a plane Jane install without add-ons will not load. It stops during the GUI load with the infamous “finishing asynchronous loading” message. Then my system becomes unresponsive. I’ve waited as long as 15 minutes. There is very little to no drive activity and I have to do a hard reset. The log.txt file is not helpful, because there are no failed to load or halt messages. Also, half of the file is corrupt. It looks like binary and not text format.

Everything else that I’ve tried runs perfectly, including DCS 2.5, IL-2 BoX, P3DV4, MISSION:ISS, and Office 365. In fact, I’ve flown DCS in VR mode for a couple of hours non-stop as a stress test, without issues.

I’m beginning to think that it might be a memory module issue, but one would think that other software would have issues as well.

It’s hard not to get discouraged, but I worked on it four hours last night without resolution. It really gets old cycling an unresponsive system. I worry about corrupting FAT tables or system files. Anyway, let you know what I find out.

Hmm…hard to believe a clean, non-modded install won’t fire up. Will it work in just demo mode without activating the key? Tried running it from another drive?

Definitely weird.

Affirmative, and I’m going to try from another drive tonight. Don’t think it’s the drive though. It was fine in my previous build, I have run diagnostics clean, and all of the BoX installs are on the same drive. They run fine.

Never give up, never surrender! :slight_smile:

image

For X-Plane, I know I am in danger of ‘I just did that’ terroritory, but I have to ask. :frog:

Did you already:

  1. Run the X-Plane Updater?
  2. Delete the Output/preferences folder in your X-Plane install directory?

XP11 seems very tied to what hardware you have, and will ‘tune’ itself fairly aggressively, i.e. cores, GPU, amount of RAM etc. There must be something that is trying to use your previous hardware profile. Blat it!

Re-Installing things often doesn’t work - all it does is put the same files back on. The trick is to find all the ‘settings’ files that get written after a hardware profile has been read on start-up and then default those puppies back to ‘go do that again’ settings.

Yes. Backed up my Custom Scenery folder, wiped the drive of X-Plane folders, and ran the Installer again. twice

I’m not going to let it beat me. Never!

1 Like

Yeah…might be worthwhile to remove all controllers too maybe. LOL… @near_blind was telling me last night that for some reason DCS is constantly polling his hardware. I think he was up to joystick #500 and something last night…

Oh man. That was brutal when elite dangerous decided my Hotas was a new device and all the keybinds got wiped.

1 Like

I’d guess XP11 only related, but if you want peace of mind about the RAM then good old Memtest86 is still probably the best thing to use. Plonk it on a flash drive, boot up from it and just check it’s all ok.

http://www.memtest.org/

Also, a bit of a long shot, but if you have that corrupted log.txt then you could send it in to support at Laminar? It might be something they see a lot. Unlikely to help, but quick to just squirrel off to them.

1 Like

Also, if that doesn’t help, as @BeachAV8R said, you could wolf-fence the issue down with things like USB devices. What I do is rather than disconnect them I use USBDeview to disable them. Sometimes when changing motherboard the existing Windows install will have confused HID references to things like sticks, the Rift etc.

Anyway, rather than spelunking in Device Manager, you can get an easy ‘single view’ with this guy:

http://nirsoft.net/utils/usb_devices_view.html

(Use the x64 version)

3 Likes

Those are really good ideas FF. Much appreciated.

1 Like

After trying everything above without success, I decided to go back to the basics. Even though I’d done this at upgrade, I verified that I had the latest firmware, then downloaded and installed all of the drivers from Asus. No joy. :frowning:

However, in my back to basics approach, I decided to reset the BIOS back to default and began tweaking slowly. I’m happy to say that I found the uh, culprit. Even though the OS and the rest of the applications were fine with my OC of my 8700/3.7 CPU to 5 MHz, XP would only handle 4.5. Once I set it there, sold loads of XP11 every time. Go figure. Now to completely reinstall the sim and a plethora of mods!

Upgrades:

3 Likes

Holy cow…that would drive me nuts. Hardware bugs are the things that drive me mad. Heck…if my internet goes out for five minutes I’m panicking that I’ll have to trace down a broken wire or something… Glad you found it!

1 Like

Gah, feel bad for not saying to try a Prime95 blended test run now. Using that even just for 10 minutes or so really shakes down overclocks - or enough to have to try altering voltages/vdrop vs temperatures.

Glad to see you figured it out - looks like a really nice build. :+1:

2 Likes

Thanks guys. Yes, lesson learned. I should have looked at the BIOS earlier in the process. I just thought that the config was so solid after that 2 hour VR run in DCS. The fans were max RPM though when I returned to reality though. :smile: Could not hear them with the headphones on flying the AV-8B. Big old turbine right behind the seat.

1 Like

XP11 threading and high CPU use (traffic, some autogen etc) all pound more cores than DCS I find.

On XP11 initial startup (first run in that demo area I think?) it might have been doing a bunch of CPU intensive stuff as well. Must have been borderline though at 4.5 vs 5.0.

Good to know. I shouldn’t be greedy. If I get 3 more years out of this box, I’ll be happy. I think that I’ve read that this CPU runs warm and that not too many folks are getting 5 reliably anyway.

1 Like