USB Hub down after RAM upgrade

Hey all,

For a few years, since my last big mobo/RAM/CPU upgrade, I’ve been happily flying with just 2 out of 4 DIMM’s used, running with only 16GB. Recently, one of my favorite electronics/hardware stores announced they where pulling these types from the store, selling off the remaining stock at €40 off. A deal I couldn’t pass up. They are the exact same, same capacity, same frequency, same clock, same cool gamer name (Corsair vengeance LPX). They have been running nice and stable (and DCS already happily went over the former 16GB limit!) but I immediately ran into a problem, my USB hub didn’t work anymore. That HUB has my stick, my MFD’s, my pedals and my occulus Rift (sensors and headset). At the time of the upgrade, I did a little troubleshooting and eventually solved the problem by shorting the CMOS (the motherboard has pins for that, it was recommended in the manual as part of USB troubleshoot). Unfortunately, that fix has stopped working now, and trying to short the CMOS again has not been productive.

  • The USB hub works on my laptop.
  • The ports are working fine, other devices work on the port my hub uses, and my hub doesn’t work on other ports either.
  • I turned off all funny stuff I could find about USB power-saving
  • The problem persists when using the XMP profile that I have been running fine for years or without an XMP loaded.
  • unplugging/replugging all the devices, or the external power connected to the hub, has not helped.
  • the only confirmation I get from the computer that I plug/unplug is in device management where I can see a “generic USB Hub” is being connected. Trying to manipulate it from device management hasn’t done anything.

I was wondering if you guys have any ideas what my next step could be, thanks in advance for any answers.

When you did the upgrade did you by chance get any Windows updates?
Wondering if there was a software change like that, which could be the issue.

If possible, see about reinstalling whatever USB controller or chipset drivers for your motherboard that cover the USB hardware and if there is an updated version while you are at it.

I would think if you had statically fried something you would have more consistent issues than this - such as the hub being totally dead, or one or more fully non-functioning USB ports.

When you say the Hub does not work - does that mean with all devices attached - or have you tried with a single device through the hub, then two, etc?

1 Like

It has all signs of a software issue, but how to go from here… hmm.

Can Windows still be booted into safe mode?

1 Like

First of all, thanks a lot for the replies, @wes and @Poneybirds!

This was one of my first tries as well, I did everything I could do to update the motherboard and chipset except flashing the BIOS (I know you can work your way around a bad flash these days but I still don’t like doing it). All my drivers were still up to date. I decided that rather than re-installing, run the repair install function for the USB driver and… it worked!! Even while the repair was still running my equipment popped back online.

I hope this fix sticks! Thanks for making me go back to look there for the issue. Now, on to rebind all my controls :slight_smile:


Glad I could help!
I know the absolute pain of PC problems, and being told to do something you did already. :grin:

Back to the virtual skies with you!