Virpil CM2 Grip problem with extension

Got my T50CM2 grip Friday, FINALLY had time to break it out and start setup today…and the software is missing a few buttons and the brake axis…


So, you set it up and the test program doesn’t recognize the buttons and the paddle switch on the base?

Can you reinstall the stick somehow? I’m not an expert on the thing, but maybe run through their calibration protocol again?

You did select the correct grip on the profile page, yes?

1 Like

Yeah you need to rebuild the profile and recalibrate the thing.

ok, so here’s where I am.

  • Software is up to date
  • Firmware is up to date
  • Only one Virpil device plugged in while updating
  • Create new profile (correct base and grip chosen)
  • Save VPC device (under profile tab)
  • Axis tab, calibrate axes. X and Y show response, nothing from Z axis.

I’ve unplugged the stick at the base end, and the base, and plugged them back in. Nothing.


1 Like

Could this be because of the VPC software fails to identify the controller PCB correctly?
Stand by…

Have a look at this also

1 Like

Saw that, but already verified I had the right grip selected. I’ve put in a support thread on the site, when I can shut down I’ll see about pulling the extension and trying the dance with just the stick in the base.

I saw in that thread that it worked without the extension.
That seems a bit strange. I though the extension either caused the entire stick to fail, or work, not just a few functions…

1 Like

I’m sure that you tried this but did you successfully flash the stick?

I didn’t see that in your description.

1 Like

I’m tempted to run continuity checks on all the pins with my multimeter, but that worries me a bit. I’m wondering if it’s a power issue though…I had the stick plugged into a motherboard port, I’ll try it next in my powered hub.

I did- there appears to be something wrong with the extension I have…?

Time to start seeing if there are any other threads about extensions failing.

1 Like

Do you have anything connected to the AUX port of the CM2 base, if that’s the one you have…?

1 Like

I do not.

UPDATE: plugged stick into a powered USB port. Everything seems to be working now for both buttons and axes, so I’m suspecting there was just enough internal resistance in the extension to drop the voltage signals from the grip to the base. Add that to your knowledge bases, folks. Will verify in DCS (what tipped me off to begin with), and get back to y’all (now that I have some time to play around with things, because 2 hour webinar).

EDIT: definitely working now.


Great! Hope that solved it for ya!

1 Like

Great that you solved it, could we split the thread from this post on?
Would really help for findability. And we can even do the “mark as solution” thingy then

EDIT: I think only @staff can do this?